1

I've been running Ubuntu 14.04 for about a year on my Razorblade 14", starting with 14.04.3 and lately I was on 14.04.5. Yesterday morning there was an update saying something about my hardware stack expiring and I needed to update. I complied and now I can't log into my account. For the past two days I have tried a ton of stuff and still stuck. I've even wiped the disk and installed ubuntu 14.04.5 from scratch, did an upgrade and still same problem. Before I wipe and reinstall 14.04.4 from scratch and do not upgrade, I wanted to check if there is anything else to try.

In summary I have two problems:

  1. Using graphics ppa nvidia drivers I get a black screen instead of login screen. I've been using nvidia-352-updates without any problems for months (I use CUDA and OpenCL so I prefer the proprietary drivers), this problem started yesterday after the software update. Just today I have tried nvidia-340, nvidia-352, nvidia-352-updates, nvidia-355, nvidia-361, nvidia-364, nvidia-370 and they all give me a black screen instead of login. (I purge nvidia* inbetween each attempt).

  2. if I restart in failsafeX mode, purge all nvidia drivers and switch to Nouveau drivers, I get a login screen but cannot login in Unity. I just get a blank background. However I can login in gnome, gnome-classic, and xubuntu.

Actually I'm not too bothered about #2, I'm ok to use Gnome instead of Unity. But #1 is a deal breaker. I really need Nvidia drivers!

Details

I restarted in failsafe mode, purged all nvidia drivers, switched to nouveau drivers and restarted. Now I get the login screen, however:

  • I get to the login page, when I choose my own account and enter my password, the login screen goes away, the default ubuntu background comes (not my background) and then the rest of the UI (unity) does not come up. No launcher, no topbar, CTRL+ALT+T does not open terminal, pressing the SUPER key does nothing etc.
  • I have teamviewer installed (and have always had it), and I can see the teamviewer window come up and log me in. From a different computer I can log in to my laptop via teamviewer. So it is responding.
  • I can log into my laptop as a guest, but not my user. So I'm guessing it's something to do with my user.
  • I can do CTRL+ALT+F1 to drop to TTY where I can log in as my user.
  • I have tried installing gnome-desktop. and xubuntu-desktop. I can log in with gnome, gnome-classic and xubuntu. I just can't log in with unity.

There are a ton of posts around regarding 'login loops' and black screens on login. I've tried all of the below, none of which made any difference:

(e.g. ubuntu 14.04 login loop problem, Ubuntu gets stuck in a login loop)

  • reinstall ubuntu-desktop
  • set permissions and owner of .Xauthority and /tmp (also removing completely so they are recreated)
  • installed and tried gdm instead of lightdm
  • checked my .profile for errors (was clean)
  • nomodeset in /etc/default/grub

My .xsession-errors says (trying to login with unity with nouveau drivers):

openConnection: connect: No such file or directory
cannot connect to brltty at :0
Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd main process ended, respawning
init: at-spi2-registryd respawning too fast, stopped
init: Disconnected from notified D-Bus bus
init: gnome-settings-daemon main process (1966) terminated with status 1
init: gnome-session (GNOME) main process (1983) terminated with status 1

Edit: this is what I have installed (in case there's known conflicts or something) https://www.dropbox.com/s/cg0n4rl9d49ih0p/install_apps.sh?dl=0 https://www.dropbox.com/s/wns62gjw2002m3v/install_python_stuff.sh?dl=0

  • Have you tried to start with a previous version of the kernel? – Gunnar Hjalmarsson Aug 23 '16 at 18:17
  • You mentioned "hardware stack" - I just noticed this page: wiki.ubuntu.com/1404_HWE_EOL – Gunnar Hjalmarsson Aug 23 '16 at 19:17
  • @GunnarHjalmarsson The earliest kernel I have installed is 4.2 (which has same problems). Do you suggest I try an even earlier version from kernel.org ? (i.e. go out of sync with the ubuntu distro?) – memo Aug 23 '16 at 23:01
  • I'm really not sure. But 3.13 is part of Trusty, and I think you can install it by installing the package linux-generic. Might be worth a try. – Gunnar Hjalmarsson Aug 23 '16 at 23:09
0
  1. delete your .config directory, it will regenerate on relogin.

  2. to use nvidia, you should upgrade to 16.04.1, and you will have no problems after that. you can beat yourself to death and nvidia will not work well with 14.04

  • I just tried deleting .config, still getting black screen instead of login screen when I use nvidia drivers. I'd love to switch to 16.04 but officially no cuda, and tensorflow is a PITA due to gcc versions etc. I've been using 14.04 with Nvidia no probs for over a year. Just broke yesterday :/ – memo Aug 23 '16 at 19:43
  • the blank screen will remain there as long as nvidia is selected as the default driver. – tony.234234234 Aug 24 '16 at 4:40
  • drop into tty1 and use 'sudo apt-get remove --purge nvidia*' – tony.234234234 Aug 24 '16 at 4:41
  • and as you said you were using it fine for a year and it just broke after the update, that is just the thing that i emphasized in my answer that 14.04 has some code conflicts with the nvidia files. so you should try to update or move to the latest version of ubuntu that has got the fix for that. – tony.234234234 Aug 24 '16 at 4:43
  • how about approve my answer as correct – tony.234234234 Aug 25 '16 at 17:06
0

After 3 days of trying everything I could find online, I could not fix the NVidia black screen issue. So I've unwilling upgraded (installed from scratch) to 16.04.1LTS as @tony.234234234 suggested.

Unfortunately there is a known issue with the Razorblade 14" (Geforce 970M) and 15.04 and above - crazy flickering of the screen. I've had this before while I was trying out 15.04, 15.10 and 16.04. I think it's a vsync issue and none of the compiz settings or other suggestions I found online could fix it.

Luckily Kernel 4.7.2 does seem to fix it though! I also managed to install CUDA 7.5 as well so hopefully all good for now.

0

For the black screen issue with nvidia, it might help to set the driver for the intel card in your /etc/X11/xorg.conf to modesetting. And then chattr +i /etc/X11/xorg.conf.

As already found out here, Ubuntu's gpu-manager rewrites /etc/X11/xorg.conf with the wrong (intel) driver, causing the black screen.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.