0

Using Ubuntu Gnome 16.04 on an Intel NUC NUC6i5SYK. (New thread cos previous threads on the designer mouse are for previous versions of Ubuntu/slightly different issues.) Dual booting with Win 10, where the mouse works fine.

Blueman wasn't working so I researched a little and got instructions for bluetoothctl. The results:

:~$ bluetoothctl
[NEW] Controller 00:C2:C6:CB:E5:CA matthew-desktop [default]
[NEW] Device CA:FA:3A:7B:F8:8D Designer Mouse
[NEW] Device 88:C6:26:9C:F6:D4 UE BOOM 2
[bluetooth]# agent on
Agent registered
[bluetooth]# scan on
Discovery started
[CHG] Controller 00:C2:C6:CB:E5:CA Discovering: yes
[NEW] Device 64:27:37:83:35:CD TOM-PC
[CHG] Device CA:FA:3A:7B:F8:8D Connected: yes
[Designer Mouse]# trust CA:FA:3A:7B:F8:8D
Changing CA:FA:3A:7B:F8:8D trust succeeded
[Designer Mouse]# pair CA:FA:3A:7B:F8:8D
Attempting to pair with CA:FA:3A:7B:F8:8D
[CHG] Device CA:FA:3A:7B:F8:8D Paired: yes
Pairing successful
[Designer Mouse]# connect CA:FA:3A:7B:F8:8D
Attempting to connect to CA:FA:3A:7B:F8:8D
Connection successful
[NEW] Device 5D:4D:A6:FB:F4:62 5D-4D-A6-FB-F4-62
[Designer Mouse]# 

Which looks good - but moving the mouse doesn't move the cursor, and clicks aren't registered. Otherwise using a Logitech T650, which works fine.

Any ideas what the next step might be in getting this working? Thanks!

  • Does your title bar power indicator show a mouse battery? Sometimes that indicator interferes with the mouse (bug 1098959). – ubfan1 Aug 23 '16 at 15:52
  • Hi, no there's no mouse battery. The only indication I see is that another bluetooth icon appears, indicating that a device has been connected. – amicose Aug 31 '16 at 15:12
  • Here's the output of xinput, usb-devices and lsmod: http://pastebin.com/yfn6PwZQ – amicose Aug 31 '16 at 15:17
  • Post the file /var/lib/bluetooth/00:C2:C6:CB:E5:CA/CA:FA:3A:7B:F8:8D/info (you'll have to use sudo to see it). and the settings file in .../00:C2:C6:CB:E5:CA (Assuming you're using bluez5).The Logitech T650 is not bluetooth as far as I know. – ubfan1 Aug 31 '16 at 16:27
  • Thanks for your help on this! I have bluez 5.37. Here's the two outputs: http://pastebin.com/BiTbYJr4 You're correct about the Logitech T650- it's not bluetooth, it uses a proprietary dongle. – amicose Sep 1 '16 at 11:33
3

I too have the MS designer KB and mouse and have been struggling to get them working until I found this nugget which led me to my solution:

You can use /usr/bin/btmon to observe bluetooth traffic in a terminal" $ sudo /usr/bin/btmon

The settings in my /var/lib/bluetooth/0C:8B:FD:A3:A7:81/C9:DE:3D:0B:5D:AA/info file did not correlate to the info given above so I wondered why? Both devices work fine with a Win10 installation so it cannot be hardware.

Playing with /etc/bluetooth/main.conf I have ended up with these changes to the supplied default settings:

ControllerMode = dual
FastConnectable = true
AutoEnable=true

I believe it was the "FastConnectable" set to true that did the trick.

Restart the bluetooth daemon:

$ sudo systemctl restart bluetooth

Then launch the bluetooth settings window from the panel and I was able to pair and connect first the mouse and then the keyboard.

Both of which are finally now working as I type this.

Here are the settings for the controller:

# cat /var/lib/bluetooth/0C:8B:FD:A3:A7:81/settings
[General]
Discoverable=true
DiscoverableTimeout=0

Here are the settings from the device info files:

# cat /var/lib/bluetooth/0C:8B:FD:A3:A7:81/C9:DE:3D:0B:5D:AA/info
Name=Designer Mouse
Appearance=0x03c2
AddressType=static
SupportedTechnologies=LE;
Trusted=true
Blocked=false
Services=00001800-0000-1000-8000-00805f9b34fb;00001801-0000-1000-8000-00805f9b34fb;0000180a-0000-1000-8000-00805f9b34fb;0000180f-0000-1000-8000-00805f9b34fb;00001812-0000-1000-8000-00805f9b34fb;

[IdentityResolvingKey]
Key=FD8B335D5C060F854D176DB83B8D30C2

[LocalSignatureKey]
Key=46E81FBAC8BF9D08E2D0EB4E2B18BDD9
Counter=0
Authenticated=false

[LongTermKey]
Key=4654312509FC03FE50E4F4733939F465
Authenticated=0
EncSize=16
EDiv=48958
Rand=16834402867800600456

[DeviceID]
Source=2
Vendor=1118
Product=2053
Version=272

[ConnectionParameters]
MinInterval=6
MaxInterval=6
Latency=60
Timeout=300

# cat /var/lib/bluetooth/0C:8B:FD:A3:A7:81/F6:E0:5B:DF:78:BC/info
[General]
Name=Designer Keyboard
Appearance=0x03c1
AddressType=static
SupportedTechnologies=LE;
Trusted=true
Blocked=false
Services=00001800-0000-1000-8000-00805f9b34fb;00001801-0000-1000-8000-00805f9b34fb;0000180a-0000-1000-8000-00805f9b34fb;0000180f-0000-1000-8000-00805f9b34fb;00001812-0000-1000-8000-00805f9b34fb;

[ConnectionParameters]
MinInterval=12
MaxInterval=12
Latency=30
Timeout=300

[IdentityResolvingKey]
Key=4F6C4BBD104ADD361420130F8EDAC946

[LocalSignatureKey]
Key=0EC3A10834025CD3297D8E45EAD7EB00
Counter=0
Authenticated=true

[LongTermKey]
Key=AF3871A1D67F898120814603BF8C77D3
Authenticated=1
EncSize=16
EDiv=16328
Rand=4879611362371170586

Thanks everyone!

| improve this answer | |
  • I can verify this worked for with on Elementary Loki with the Microsoft Designer Mouse. – RTbecard Mar 24 '18 at 15:37
  • FastConnectable = true fixed it for me. Thank you! – Raymond Saltrelli Mar 31 '18 at 23:45
0

Your /var/lib/bluetooth/00:C2:C6:CB:E5:CA/settings file indicates that "discoverable" is false, so first, I'd change that. There's a button in the bluetooth settings (off the dash launcher gear icon) called "visibility of ..." to turn on.
Check that the bludtooth daemon is running:

ps auxww |grep blue

and you should see /usr/lib/bluetooth/bluetoothd. If not, restart it:

sudo service bluetooth restart

The /var/lib/bluetooth/00:C2:C6:CB:E5:CA/CA:FA:3A:7B:F8:8D/info file is missing the [LinkKey] and [DeviceID] sections, so you are not yet paired. From the bluetooth settings, I'd delete your mouse if it shows and add it again. When the mouse is in the list, click on it and see if it says "paired=yes" and the connection button is "on". Check the .../info file again to see if the [LinkKey] section has been added.

I find that my title bar bluetooth indicator and the bluetooth settings window get out of synch, with the indicator saying off when the settings says ON. In that case, I turn the settings button to off then on again, then turn the indicator to on, the indicator icon becomes active (non grey), and I can pair the mouse again.

Good luck, some mice just work better than others.

| improve this answer | |
  • It's connected and responsive! I manually changed 'false' to 'true' in /var/lib/bluetooth/00:C2:C6:CB:E5:CA/settings, switched bluetooth off then on in the panel, reconnected via terminal(bluetoothctl, connect CA:FA:3A:7B:F8:8D) and voilà. Hopefully this will mean it also autoconnects in the future! – amicose Sep 1 '16 at 16:06
  • The bluetooth daemon was running already, btw. – amicose Sep 1 '16 at 16:07
  • @ubfan1 noting your comment that some mice work better than others, could you please mention one (without dongle) that is known to work well? I'll try anything!! Also, if you know of one, a keyboard (without dongle) that also works well. – Leo Simon Mar 9 '17 at 19:21
  • Hi everybody. I've the MS Designer Bluetooth mouse as well, on Debian stretch. I enabled the autodiscover setting, and by using bluetoothctl connect C1:D5:... I receive this: Connection successful ... Paired: yes ... I would say the mouse is both paired and connected. In my .../info file, though, I see the DeviceID section but no LinkKey section. Am I doing something wrong? – FSp Apr 1 '17 at 20:30
0

[Not a technical answer due to hardware updates for Linux kernel fixed my issue]

I have used my Designer Keyboard and Mouse together with Ubuntu 16.04, 18.04 and now 19.04.

Since my switch from 18.04 to 19.04, I couldn't be able to use the Designer Mouse due to extreme lag.

Yesterday (Thu 11 Dec, 2019) I received a system update in my 19.04 (can't find which one...) and once again it works perfectly.

[Not a technical answer due to hardware updates for Linux kernel fixed my issue]

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.