1

Ubuntu 14.04.5 LTS

PHP 5.6

Apache 2.4

I followed these instructions, and used oci8-2.0.12 instead, the shared object exists but after I run php5enmod oci8 then service apache2 reload phpinfo() doesn't list oci8.

I checked the apache logs and tested the config and no errors are present. I just gave www-data owner permissions on the instant client folder and still nothing.

Is there a log for php5enmod I need to know about or did I skip a step?

EDIT: I decided to try to disabled a module using phpdismod and it didn't work either.

0

I got it, because I didn't not change major versions and still had PHP5 I assumed that php5enmod oci8 would enable the module, it does BUT IN THE WRONG FOLDER.

php5enmod adds a shortcut to the ini /etc/php5/apache2/conf.d but the 5.6 install is read from /etc/php/5.6/apache2/conf.d. Using phpenmod instead of php5enmod solves the problem. One character difference, hours wasted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.