0

I initially installed Ubuntu 16.04 with gnome shell and everything that the flavor comes from. After a while nautilus was being a resource hog so I switched to Nemo since I didn't like it anyways.

But now, I cannot open my trash. Trying to do so gives this error:

Error: Failed to execute child process "/usr/lib/gvfs/gvfsd-trash" (No such file or directory) Please select another viewer and try again.

~/.local/share/Trash works perfectly fine however. This is definitely and issue with nemo somewhere.

The solution I thought of but couldn't apply is the change the directory for the trash folder to directly go to ~/.local/share/Trash/files instead of running useless stuff. Any ideas how to do that?

  • 1
    Have you tried reinstalling Nemo? – wjandrea Aug 23 '16 at 15:08
  • ~/.local/share/Trash/files and trash:/// are not the same thing. It wouldn't help to change the directory for the trash folder. – wjandrea Aug 23 '16 at 15:11
  • @wjandrea Yes I have. – Slava Knyazev Aug 23 '16 at 21:18
0

I had the same problem. When I started nemo from the command line (first killing it with "nemo -q") and tried to open "trash", I got the following message:

Nemo-Share-Message: Called "net usershare info" but it failed: »net usershare« gab den Fehler 255 zurück: info_fn: file /var/lib/samba/usershares/comics is not a well formed usershare file. info_fn: Error was Path is not a directory.

I had created a share which I deleted later without un-sharing the folder. Solution: looked in the given file "comics" for the original path, created the folder again, shared/unshared and deleted it. => "trash" is working again :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.