I know this is quite a common question being asked and this below seems to give a detailed explanation but the thing is, I still couldn't get my sdk running why? (still really new with linux hierarchy and installations)


I have followed a few threads to put the $ANDROID_HOME and $PATH into my ~/.bash_profile but just wouldn't work.

I am starting to doubt if I am putting the correct directory. (Even though I tried pretty much all and still no luck)

I downloaded SDK from and SDK development site and extract the folder into /home/et-ubuntu-pc/App/ the folder extracted is named android-studio and this is the location which I expect my studio is installed after I went into /home/et-ubuntu-pc/App/android-studio/bin/ and ran /.studio.sh but in the other forums they keep on saying $ANDROID_HOME is to insert with /where-you-unpacked-the-sdk/sdk/ but my android-studio folder doesn't have an sdk folder at all. anyways I tried. no luck then I figured there's an Android folder at my home root /home/et-ubuntu-pc/ and inside that Android folder it's a SDK folder so I tried using that too which is /home/et-ubuntu-pc/Android/SDK still no luck.

I am totally confused what I should be putting in my $ANDROID_HOME now.

Can someone please give me a hand?

  • What's your sdk version? – Anwar Aug 23 '16 at 2:34
  • @Anwar 2.1.3, downloaded 3-4 days ago – Dora Aug 23 '16 at 2:58
  • You said, "I went into /home/et-ubuntu-pc/App/android-studio/bin/ and ran /.studio.sh", what happened after you ran it? – Anwar Aug 23 '16 at 6:18
  • You don't put $ANDROID_HOME in that file, but export ANDROID_HOME=/path/to/dir . To test it you can use echo $ANDROID_HOME in the terminal. – Timo Aug 23 '16 at 8:12
  • @Anwar after I did that, the Android studio program loads up – Dora Aug 23 '16 at 20:10

This is one stupid mistake. export $ANDROID_HOME and export $PATH in .bash_profile is the reason why the path environment doesn't work.

I have to put both $ANROID_HOME AND $PATH into .bashrc

  • I should have detect this long ago. Because I knew Ubuntu ignore. bash_profie. +1 for solving own problem – Anwar Aug 24 '16 at 3:53
  • @Anwar is this because of the new ubuntu? I always see people keep on saying use .bash_profile for ubuntu and pretty much no one complaint about it like I do ... hah – Dora Aug 26 '16 at 3:11
  • No. At least it was in 14.04 too! Ubuntu uses .bashrc. For a new user, there will be no .bash_profile – Anwar Aug 26 '16 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.