8

I've just installed Ubuntu 16.04 on an Acer Aspire E5-552-T574 and I'm dual booting with Windows 10.

Touchpad works just fine in Windows but in Ubuntu it only works before I log in and for a few seconds after that but then it just stops working. Plugging in a usb mouse works fine though.

xinput gives me the following output for my touchpad:

~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer            id=4    [slave  pointer  (2)]
⎜   ↳ Areson USB Device                     id=11   [slave  pointer  (2)]
⎜   ↳ Areson USB Device                     id=12   [slave  pointer  (2)]
⎜   ↳ SYN1B81:01 06CB:2970 Touchpad         id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard           id=5    [slave  keyboard (3)]
    ↳ Power Button                          id=6    [slave  keyboard (3)]
    ↳ Video Bus                             id=7    [slave  keyboard (3)]
    ↳ Power Button                          id=8    [slave  keyboard (3)]
    ↳ Sleep Button                          id=9    [slave  keyboard (3)]
    ↳ HD WebCam                             id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard          id=14   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys                      id=15   [slave  keyboard (3)]

Also here is the relevant touchpad info:

~$ cat /proc/bus/input/devices
...
...
I: Bus=0018 Vendor=06cb Product=2970 Version=0100
N: Name="SYN1B81:01 06CB:2970 Touchpad"
P: Phys=i2c-SYN1B81:01
S: Sysfs=/devices/platform/AMD0010:00/i2c-6/i2c-SYN1B81:01/0018:06CB:2970.0003/input/input13
U: Uniq=
H: Handlers=mouse1 event13 
B: PROP=5
B: EV=b
B: KEY=6420 10000 0 0 0 0
B: ABS=260800000000003

Some people have been suggesting running the following command:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

also this command:

gconftool -s -t bool /desktop/gnome/peripherals/touchpad/touchpad_enabled true

That didn't seem to work for me. Then I went into the grub and added "i8042.reset" to the line "GRUB_CMDLINE_LINUX_DEFAULT" and then updated the grub:

~$ sudo nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash"
~$ sudo update-grub

That didn't work so I tried to disable and enable the touchpad:

xinput --disable [id]
xinput --enable [id]

Just replaced "[id]" with 13 in my case... but that didn't work either.

I'm not really sure what more I can try, anyone got any suggestions?

EDIT: I can use the touchpad if I change it from Advanced to Basic in the BIOS but that's not much of a solution since scrolling and tapping don't work that way.

8
  • Does this answer help? askubuntu.com/a/798175/231142 – Terrance Aug 22 '16 at 23:13
  • no it doesn't seem to work since it's already set to 1: "Device Enabled (137): 1" – HaSte Aug 22 '16 at 23:32
  • Just thought I would ask. This is a good question. Hopefully someone might have stumbled across this before and has an answer for it. – Terrance Aug 22 '16 at 23:38
  • Yeah, thanks for the suggestion though! And I hope someone has an answer for this. – HaSte Aug 23 '16 at 0:32
  • Have a look at dmesg | grep Touchpad. It sounds like the mouse/trackpad works until X gets a hold of it. That would probably be a driver issue. Also look at grep pad /var/log/Xorg.0.log. Hopefully, somebody is complaining about it and will give you a clue. If you go into your system settings under touchpad, does it show up? – Joe Aug 30 '16 at 7:38
4

I had the same problem (trackpad stops working after login). On my Asus SonicMaster laptop, pressing Fn-F9 fixed it (it was apparently disabled and Fn-F9 re-enabled it).

1
  • Oh my god, I didn't know this was a feature. – pvaesrtdoe Jan 16 at 21:28
1

I have the exact same problem on a Dell latitude. Also with dual-boot with windows. But i'm not sure how that is related.

Anyway, i'm usually able to bring the touchpad to work by switching to tty5 Ctrl + Alt + F5 and then back to tty7 Ctrl + Alt + F7

However, i would also prefer a solution that prevents the touch-pad from freezing in the first place.

0

Check with the settings in synclient

You can change settings as follows: synclient 'TapButton1=1'

If typing synclient in terminal and hitting enter asks you to install xserver-xorg-input-synaptics then do it by typing sudo apt-get install xserver-xorg-input-synaptics and pressing enter. This should fix it or else yo would have to manually set values for synclient commands of touchpad movement and add those commands to the list of startup programs .

I am currently using elementary OS juno and it didn't give me any problem but I had the similar problem with ubuntu 16.04 where double finger tap won't work. synclient helped me to fix it.

Please mark the answer as correct if it solves your problem.

0

For me, the touchpad used to work fine for some time, and suddenly its movement functionality used to stop. I can click, right click, double/triple click, they all worked but the cursor doesn't move. Strangely enough, I used a guest login after seeing this, the touchpad worked fine there. After spending some time looking for solutions on the Internet, I checked

$ xinput --list-props 'Elan Touchpad' # That's my touchpad name, as shown in $ xinput list

it showed the following among other information:

Synaptics Off (284): 1

To unset it:

$ xinput --set-prop 'Elan Touchpad' 'Synaptics Off' 0

and the touchpad resumed working with its full functionality.

At the moment, I am not sure what sets the above value, I will update this answer once I find it (or if anyone else finds it, you're welcome to update this answer).

-1

On Lenovo Thinkpad x220 press (Fn + F8) to re-enable it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.