5

I did some googling and found similar complaints with older versions of Ubuntu/OSX, but none of the suggestions in those worked, seeing if anyone has any updated advice.

I am running VirtualBox 5.1.2 on OSX 10.11.6. I've installed Ubuntu 16.04. The VM has 8GB of RAM and a 40GB disk size. Right now I have 2D and 3D acceleration turned on for the VM, but turning them on and off doesn't seem to affect anything.

Symptoms are general lag involving anything with the Unity UI. Even starting with typing my password into the login screen. I type my password, then watch as the characters appear one at a time with about a half second delay between each one. Typing in universal search is a similar experience. Dragging windows around is also laggy. Mouse clicks themselves don't seem to be similarly delayed though. Typing in say, the address bar in Firefox is SLIGHTLY delayed, but typical of going through a VM and not nearly to the extent of the delay within Unity. Typing in Terminal is pretty responsive as well. Just seems to be actual Unity UI things.

Any ideas?

  • 1) Have you installed Guest Additions? If not, install them before continuing. 2) Please add any other details of what you have already tried. – wjandrea Aug 22 '16 at 21:36
  • @wjandrea Were you able to get this working properly? I'm about to do a dual-boot, but VirtualBox would be my first option. – Aaron Bratcher May 9 '17 at 13:48
4

This is most likely caused by the absence of 3D acceleration (settings -> display -> enable 3d acceleration).

Unfortunately, at this time, this option does not work for mac. See this link

  • I can confirm this option works for mac and virtual box 5.2.4. Enabling the 3D acceleration solved the problem for me. – jbarrameda Dec 27 '17 at 16:44
  • Worked for me too – jasonlam604 Oct 1 '18 at 18:44
  • were you able to install guest additions? The link provided clearly states that mac hosts do not support them, were you able to solve this without installing them? – João Matos Oct 2 '18 at 8:55
1

Have the same behaviour as ozma on my MacBook Pro 13" from 2017 with top specs. Enabling 3d acceleration improved the things a bit, but still far from perfect.

0

Start your Ubuntu VM,

go up-top to the main VirtualBox menu, click on Devices, and then ...

click on Insert Guest Additions CD images....

A terminal will open , follow instructions

... when complete, restart the VM.

NOTE

This answer is for macOS Mojave users who are facing this issue after they installed Ubuntu 16.04 on VirtualBox version 5.2.20 ... Nonetheless, others are welcome to give it a try :)

0

With macbook pro 2017 with external display. When the vm window is was on the laptop's screen, it was very slow. I moved the window to the external screen and it started running faster (* my external is defined as primary) I can't explain why, this is just the way it was.

0
  1. Enable 3d acceleration.
  2. Install guest additions package for Mac.

Following these two steps drastically speed up my machine. Make sure you restart after making these changes to observe it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.