1

I have a VPS pre-installed with Ubuntu 14.04 version, it was my choice.

Can someone explain why after the host name change, terminal is no longer using colors?

I double tested that host name changing causes it. Also when I changed the host name back to original and reboot, the Colors didn't return. Why?

UPDATE after comment:

Fresh instance of VPS looks like this ls command: enter image description here

Magically after hostname change, all coloring is lost (host name has been masked) enter image description here

So far compared hidden files in /etc/skel/ and remain the same, but inspected only visually so maybe missed something.

The core of this question is why lost colors, the answers on how to fix it are secondary concern, so please do not mark as duplicate.

13
  • Can you provide an example of when it used to use colors? Aug 22, 2016 at 19:54
  • Updated the question. Aug 22, 2016 at 20:59
  • Have you modified or deleted your /home/username/.bashrc? Cheers, Al
    – heynnema
    Aug 22, 2016 at 21:04
  • No, nothing, just renamed hostname, that's why is so unusual to me. I thought that maybe linux is doing the trick to let you know hostname has changed,, or maybe private key no longer valid due to hostname not matching. When restore to original initial name still no colors Aug 22, 2016 at 21:11
  • 1
    Have you tried ls -l --color="always"? Aug 22, 2016 at 21:36

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.