0

Just bought a My Passport Ultra (WD) USB HDD. When I connect it, the following message appears:

This location could not be displayed. Sorry, could not display all the contents of "HDD LABEL" : Error when getting information for file '/mountpoint/bin: Input/output error

I tried it on two different computers running 16.04. On one computer the problem disappeared after messing around a bit (mounting unmounting). And I was able to copy files just fine.

Then, on the other machine, I got the same message, and it didn't go away. However, it's mounting! I'm able to read and write through terminal.

Output of fdisk -l shows that it's ntfs with Microsoft basic data flag.

Any ideas?

Is it a nautilus bug?

1

Well now a days OEM provides some additional layer of security which makes it difficult to use it with ease. So I recommend to format the whole Passport using Gparted - Graphical application which you could be able to install it via control center. By using terminal you can issue the following command to install the same.

sudo apt-get install gparted

Then format your Passport to ext4 and use it trouble free.

If somehow you fail to format it using gparted or after that issue persists, its better to format the Passport using Windows and then connect it again to Ubuntu , then you should be able to see and mount it. Then use gparted to format using ext4.

  • Thanks! The problem solved after a quick format using windows (virtual machine). I kept the defaults though so I could connect it to windows machines in the future. – imesh11 Aug 22 '16 at 17:37
  • The problem is that you formatted over the WD Windows applications that were on the external disk. Cheers, Al – heynnema Aug 22 '16 at 19:43
  • I actually had no choice because Windows complained too and required formatting the disk. Anyway, works like a charm without the applications. – imesh11 Aug 24 '16 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.