I have run into a lot of conflicting information for this laptop, and I want to warn you all about a couple of things before you jump to conclusions.

1) Lenovo has several Laptops sold under "100s" - some with Celeron others with Atom processors. I am referring to the Atom notebooks here.

2) There is a lot of information suggesting that a 32bit EUFI bootloader is required for these, but I have found nothing in the bios suggesting this.

3) These laptops have very limited bios. You cannot edit the boot order! You cannot disable EUFI!

The complete list of editable options in the bios include:

  • Secure boot (on or off)
  • Reset to setup mode
  • Restore Factory Keys
  • Hotkey mode. (on or off)

I am serious, that is it.

If you enable the boot menu you only get Windows Boot Manager no matter you have on the USB drive. Other options exist but are greyed for unknown reasons.

Does anyone know how to get Linux onto an Atom with such a restrictive bootloader? I have seen threads that suggest it's possible, but no one has described the absolutely limited boot environment I have encountered.

Will booting from USB magically become available if I arrange an image with a 32bit EUFI bootloader?

How do I troubleshoot this?

  • Can't give a specific advice, but just one more thing to pay attention to: some time ago Intel purchased a bit of hardware of Imagination Technologies company, and fashioned into Intel GPU model-names. Those GPUs being universally reviled: there's no system that has good drivers for them (even first developed Windows drivers have problems). So, be aware: your Atom CPU might have such a card. Those GPUs are collectively know as PowerVR based GPUs.
    – Hi-Angel
    Aug 22, 2016 at 14:58
  • All the specs say is Intel integrated graphics so, it's hard to tell if that will be the issue Aug 22, 2016 at 15:04
  • Just find the model of the Atom CPU, then search which GPU is bundled with that (I struggle to say whether Atom has GPU embedded into CPU, but usually they are bundled with the same integrated graphics). Besides, you could just walk to a shop, and ask consultants to determine the GPU.
    – Hi-Angel
    Aug 22, 2016 at 17:25
  • I bought the thing from best buy. Guaranteed they will just say "intel integrated graphics" which is what Lenovo's site says. Still waiting to see if I can even defeat the BIOS of this thing to get a live image going. Aug 22, 2016 at 17:37
  • 1
    Good news: first, I found your GPU and it seem to be supported very well. Its GNU/Linux OpenGL even higher than supported on Windows (4.3 vs 4.0) :Ь Second, your notebook seem to be a harddie to get installed anything there, but someone seems already was solving the same problem with the same notebook.
    – Hi-Angel
    Aug 22, 2016 at 19:47

6 Answers 6


I was able to install Lubuntu 17.10 onto a Lenovo Ideapad 100S, I think mine might be a little later generation (14-1BY) because the bios does allow modification of boot order, and other things I'm used to in a bios.

Regular install of just the standard 17.10 64-bit iso for Lubuntu did not work; booting into the LiveCD was fine, install seemed fine, but then it wouldn't boot on its own. Through searching threads like these, it seems the Ideapad really does need a 32-bit booter.

I was able to get there (pointed to by other posts like this) using isorespin.sh. I respun the lubuntu 17.10 64-bit iso with options --atom -u -s 2GB (-u updates to latest kernel, and -s makes a persistent partition, because I thought, if this fails, at least I'll have a more usable bootable USB). Check also respun ISOs (suitable for Intel Atom and Intel Apollo Lake devices).

Before, with preinstalled Windows 10 and Quickbooks and Chrome and THAT'S IT, the measly 32gb drive was full and screaming about windows updates it couldn't apply because it had no room. It's irresponsible of Lenovo to make a pc with a drive that small and sell it with windows 10 on it. I pity all the less-computer-literate, low-income households that bought one of these because of the price, and found it largely unusable.

Now with Lubuntu installed I've got 22GB drive space available! More than I'll ever need because this box will only ever need to be used for browsing (including document and spreadsheet writing in Google Docs).


The problem with installation is 32 bit UEFI (yeah, despite the 64 bit CPU), so the simplest solution is to find a 32 bit distro, shipped with EFI loader. You still could install 64 bit distro, but it's a bit tricky. Here's a list of helpful links you'd be interested in: someone installing Ubuntu on the same notebook, experimental Fedora for Bay Trail (non official), Archlinux topic on alike installation.

Just in case if a distro doesn't boot: make sure that it got 32 bit ….efi file, probably somewhere down the /boot/ or the /efi/ directory.

There's a bigger problem: you've got a System-On-Chip called Bay Trail, and Intel is struggling yet to supply good support (which is funny, given the number of engineers, and that Bay Trail is in production). Most of the issues are fixed as of kernel 4.7, except that there's no sound.

You can track the process of solving the bug with sound here. I'd recommend to hold with installation, while it gets solved (or, just in case you're a programmer, you could try to join the fun of getting the sound up and running).

  • I've tried USB drives with 32 bit distros, the bios will never let me select any other media besides windows Aug 23, 2016 at 12:15
  • @JohnDunlap did you check the ….efi file on the media?
    – Hi-Angel
    Aug 23, 2016 at 13:38
  • Not yet, but it wont even give me the option to try. You think the bios is smart enough to detect an incompatible bootloader and prevent me from selecting USB media as an option? In the past with other computers, I've had all kinds of incompatible bootloaders and the BIOS happily let me to boot into them, to my doom. Aug 23, 2016 at 14:53
  • 1
    @JohnDunlap UEFI works different from BIOS, it searches for some standartized files on FAT-formatted partition, and tries to load it (given multiple of them, it should offer a choice menu). From the point of the discussion, an important difference is that UEFI does the switch real-mode → protected mode, then executes the actual OS loader. So it have to differ 32 bit loader from 64 bit ones, and to ignore non-matching architecture. And for the record, hacks are present to load 64 bit system even from 32 bit UEFI.
    – Hi-Angel
    Aug 23, 2016 at 16:11
  • 1
    if anyone is still struggling with installing ubuntu on lenovo 100s, use this tutorial suggested by ubuntu wiki Jan 27, 2017 at 22:25

I've been struggling to get linux on mine with varying levels of success. I'm currently running 16.10 from a portable hdd and everything works! Wifi, sound, bluetooth, and the battery indicator as well. I used the 16.10 iso from linuxium. This man is a genius, and his work is mainly aimed at getting linux to run on the Intel Compute Stick, which also uses the same hardware as the Lenovo 100s-11IBY. It had no issue with booting or anything, did not even have to manually add the bootia32 file. I would say this is about the only way to get everything to work without being an absolute linux master.

He provides images for Ubuntu, Xubuntu, Lubuntu as well as MATE.


Just got ubuntu running on the lenovo ideapad 100s-11IBY, running from an external usb flash drive.

Here's what had to be done:

  1. Download linuxium latest build. This is because the guy solved the problem of having to have a 32bit boot loader with a 64bit OS. He also included a more recent kernel (4.12) instead of the one shipped by default with ubuntu 17.04 (4.10).
  2. Burn the iso on an external flash drive with rufus on windows (or use dd on another linux)
  3. During boot Press Fn+F12 to boot from the drive.
  4. After installation download the latest firmware from http://archive.ubuntu.com/ubuntu/pool/main/l/linux-firmware/?C=N;O=D
  5. Install it with sudo dpkg -i linux-firmware_1.xxx_all.deb (Had to do this to get wifi working)
  6. reboot

The following is working at the moment:

  • Wifi (after point 5 above)
  • Loudspeakers audio
  • Performance is ok (no prob viewing youtube)
  • Shutdown
  • brightness control keys and audio keys
  • Shutdown
  • USB

Not working:

  • Not sure if the battery display is okay
  • Can't come out of suspension mode.
  • Sound through the headphones
  • Sound on the loudspeaker works sometimes.

Hope it helps.


You can try to use Ian Morrison’s ISO disk images which has been customized/respun using isorespin.sh script (check GitHub mirror repo). These created ISOs are suitable for Intel Atom and Intel Apollo Lake devices.

  • Atom (-i ubuntu-18.04-desktop-amd64.iso –atom)
  • Apollo (-i ubuntu-18.04-desktop-amd64.iso –apollo)

Then flash the OS image onto USB using dd.

See also: Install Ubuntu 14.04 LTS on the 2GB Intel Compute Stick.

  • This looks like an ad to me... Aug 11, 2018 at 10:29

I got it to install for me:

  1. Erase all existing partitions and create one FAT32 partition, prior to installation, using GParted (found on Ubuntu live disk).

  2. Use the following BIOS settings: UFEI enable, USB boot enable, Secure boot enable, Intel trusted platform disable, Optimize OS Defaults disable.

  3. Set boot order: move USB to first!!

It was a pain to get it figured out, but I finally got it to work, and so far, everything (hardware) is working beautifully!

Hope this helps someone out there; they don't make it easy to install these days, but when it does, it makes an excellent (and cheap!!!) Ubuntu laptop.

Not the answer you're looking for? Browse other questions tagged or ask your own question.