2

I have Ubuntu 16.04 dual booted with Windows 10 on an HP laptop. The software updater was updating software. Half way through, it gave some error, got stuck and the window became unresponsive. I was in a hurry so I just closed it and shut down. When I tried to turn on Ubuntu again, after i entered the password the screen with only the mouse pointer comes and it's stuck on that(blank screen). The mouse pointer moves but it won't open the desktop or anything.

I don't remember what was in the software updater window but it had some error related to perl.

7
  • Don't bother logging in using the graphical interface. Can you log in using the text console? Press the keys Ctrl Alt and F1 at the same time, and you'll get a text-based login. At that point, type in your username and your password. If you get a line stopping with a $, we have something to get started trying to fix this. (Disclaimer: I recently helped family who had basically the same issue you had, at least from the description. I assume we can fix it similarly) [Edit: the password will not echo. It wil seems as if you type nothing. No * signs to indicate typed chars.] – jawtheshark Aug 22 '16 at 9:41
  • Yes this gave me a line ending with $. – Sss Aug 22 '16 at 9:45
  • Perfect! Start off typing: sudo apt-get update. I don't think it will give any errors. Now, when that's done, type sudo apt-get dist-upgrade. It will most likely ask you whether it it needs to install whatever it proposes to install. Say, yes. It will now continue the upgrade. It will ask you questions during this process. Accept the defaults on those questions. – jawtheshark Aug 22 '16 at 9:48
  • I ran sudo apt-get update and as it ended the last line said 'dpkg was interrupted, you must manually run "sudo dpkg --configure -a" to correct the problem'. Should I do that now, before your second command? – Sss Aug 22 '16 at 9:58
  • I ran all the commands and it returned to the line with $. What do I do now? – Sss Aug 22 '16 at 10:38
3

What happens here is that you have a system that is half-upgraded and got interrupted. Alas, it makes it hard to login via the normal graphical login. That is no big problem, as long as you can get into your a shell (terminal) in order to kick off the upgrade again.

So, where can you find this shell? Most Linux installations offer you a text-only interface, totally separate from the graphical interface. You can typically get five different logins (called "consoles") and you access them by hitting Ctrl, Alt and F1 (or F2...F5). To get back to the typical GUI interface, hit Ctrl, Alt and F7.

Start off by hitting Ctrl, Alt and F1. You now get presented by a text screen containing something like this:

Ubuntu 16.04.1 LTS my-machine-name tty1

my-machine-name login:

At this point type your username and press enter. The following line will appear:

password:

You now type the password of your username. It will look as if nothing is typed. There are no is no "echo" as it's called. You won't see * or anything appear as you are used to in normal password fields. Press enter after you entered the password. You will get more text, like this:

Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-34-generic x86_64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage

4 packages can be updated.
4 updates are security updates.

Last login: Sat Aug 20 19:30:47 2016 from 192.168.2.4
my-user-name@my-machine-name:~$

This last line is your prompt. You can enter commands here, just like you do on the terminal application.

Let's kick off the update process again. Normally you start with "updating" the repositories. It's probably not necessary, but it's good practice to do so:

sudo apt-get update

At that point, we're ready to kick off the distribution upgrade again, which can be done by:

sudo apt-get dist-upgrade

You now have a lengthy process of package installations. It will ask questions: Just take the default answers. Especially if you don't understand the question.

After a while you return to the prompt. You can now reboot.

sudo reboot

After reboot, everything should work again. If not, repeat the process until the sudo apt-get dist-upgrade is not doing anything any more. This will look like this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
2
  • Hi. there, I am getting upgrade succeeded in SHell mode, but when I try to reboot, I do not get graphical desktop, the only messaege y get is that "no boot option" , sometimes I get the login getty screen. I type my password. but it syays frozen. I am pretty sure there should be a solution. How should I troubleshoot? – Ken Sandoval Oct 20 '16 at 15:49
  • The "no boot option" message might be your BIOS/EFI. Hard to say. Do you get the Ubuntu logo on bootup? If you occasionally get the tty after all, you might have a disk that's dying. Normally computers shouldn't "occasionally do something" – jawtheshark Oct 21 '16 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.