0

I'm trying to create a custom ISO so I don't have to always reinstall openbox.

I removed ubuntu-session and installed openbox. Booting the ISO works, but when I boot it up after installationf, it says "failed to start session" in LightDM. Even if I don't remove ubuntu-session, it does the same and I have to actually choose a session in LightDM.

I have a .dmrc included by default in the home folder with openbox set. The installation seems to overwrite it with "ubuntu," but even if I get int a tty and change it back, it still fails to start the session... I tried including a lightdm.conf in /etc/lightdm, but it doesn't seem to fix the problem either. Maybe it's in /usr/share/lightdm/lightdm.conf.d?

Thanks a lot to anyone who can help.

0

I feel really silly now. I had tried creating a custom lightdm.conf in /etc/lightdm/, but I had the session set as "openbox-session."

For anyone out there reading this, the name must match the file in /usr/share/xsessions. openbox is not like gnome-session, ubuntu-session, etc. It is just openbox.

0

I am also trying a Ubuntu Server + Openbox configuration. I have bumped into lightdm "Failed to start session" :-) thanks to your posting I manage to work around it... i think... what i have done: i have copied /usr/share/xsession/openbox file to /etc/lightdm/lightdm.conf/openbox and I have created inside /etc/lightdm/lightdm.conf a 50-myconfig.conf (sudo nano /etc/lightdm/lightdm.conf/50-myconfig.conf) file (based on the info from here: https://wiki.ubuntu.com/LightDM) with the following content:

[SeatDefaults]
user-session=openbox

now I manage to login into openbox

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.