No idea what's wrong with my laptop. On the Power settings page, it's set to Suspend when the lid is closed, but for the last few days - out of nowhere, having not edited any power settings myself - whenever I open up my laptop lid the laptop boots up from scratch, so it clearly isn't going into hibernation anymore.

It's a Dell XPS 13 (9350) on 16.04 if that helps.

Thank you!

  • I have had this problem twice now with my Dell E5570. Cannot remember for the life of me how I fixed it the first time, but this time (after reading this post), I actually added back the #'s into /etc/systemd/logind.conf commenting out those 2 lines . #HandleLidSwitch=suspend #HandleLidSwitchDocked=suspend – Gilbert Eaton Jul 26 '18 at 21:42

With sudo powers open up /etc/systemd/logind.conf and look for the following two lines:


If they begin with a hash tag (#) remove it and set your option to ignore, poweroff, reboot, halt, suspend, hibernate, hybrid-sleep, lock or kexec. More details can be found at Power Management

This worked for me and hopefully works for you too.

Bug Reports

There are many bug reports starting in August 2016 with Linux Suspend / Resume issues. This bug report has lots of solutions. One comment #140 has grub command line changes that are confirmed to work:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'"

If this doesn't work, by all means check out the other solutions in this bug report. Also check out other bug reports using google search string: "Resume shuts down 16.04"

| improve this answer | |
  • I typed in 'sudo xdg-open /etc/systemd/logind.conf' and removed the hashtags from before those two items and clicked Save. I'll let you know if that worked. Cheers. – Matthew L Aug 23 '16 at 15:45
  • So how did it go? – jan groth Apr 19 '17 at 2:37
  • 1
    I tried the above, rebooted, logged in, closed the lid, opened it again --- nope: it shut itself down. – bluppfisk Jul 30 '17 at 3:40
  • @bluppfisk You can search other questions on "resume shuts down". If you can't find anything solving your problem post a new question. Make sure to list your computer make and model, CPU, GPU and Operating System version. – WinEunuuchs2Unix Jul 30 '17 at 6:26
  • @WinEunuuchs2Unix, I think that would make a duplicate question. Because I have the exact same hardware and OS. – bluppfisk Jul 30 '17 at 13:13

What worked for me for Ubuntu 14.4, for suspend is

sudo apt-get install linux-generic-lts-utopic

and then reboot the system.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.