I installed Ubuntu 16.04 AMD64 from the scratch recently, and I am facing a problem with the Compose key:

  • I am using the Compose key as <Multi_key> for some characters in a self-defined ~/.XCompose file.
  • In the keyboard settings, I have activated the Compose key.
  • In my profile, I use the following settings (as recommended in other threads):

~/.profile :

export GTK_IM_MODULE="xim"
export QT_IM_MODULE="xim"
export XMODIFIERS="@im=none"


  • The Compose key does work in the Terminal, in particular in vim, and also in the Dash search field for applications.
  • It does not work, unfortunately, in Firefox, Chrome, LibreOffice, and Gedit.

So, the settings do have effect, but not for all applications.

Why? What am I missing?

  • 5
    Possibly you run into bug #1573755. One way to find out is to create a new user and use the same ~/.XCompose file there. As regards the variables though, I'd recommend to drop those lines in ~/.profile and set the input method "XIM" from the Language Support tool instead. – Gunnar Hjalmarsson Aug 21 '16 at 16:44
  • 2
    I dropped the lines in ` ~ /.profile` and switched to input method "XIM" from the Language Support tool instead - the behaviour didn't change. BUT: I created a new user and copied the ` ~ /.XCompose` to his home directory. And, indeed, the Compose key worked there in LibreOffice! So you seem to be right, that I am a victim of that bug. Although, strangely enough, the reporter of that bug has the Compose key working precisely in those apps for which it does not work for me ! – rplantiko Aug 21 '16 at 17:13
  • 3
    So then it's a problem in $HOME somehow, i.e. as in the bug I mentioned. Unfortunately I'm not able to tell more at this time. @wjandrea: Right, that's precisely what the OP did when activating the compose key in keyboard settings. (Same in 16.04.) – Gunnar Hjalmarsson Aug 21 '16 at 17:26
  • 1
    Thank you, Gunnar - I put me on the watchlist for that bug and added the information about the affected applications. – rplantiko Aug 21 '16 at 17:28

I had a similar problem with the Compose Key upgrading from 14.04.3 to 16.04 (US-keyboard used also for german, french and italian). My choice for the compose key was the RightAlt key (al least for the last 10 years). After many unsuccessful trials and after searching everyhere for help I understood that I was fallen victim of the bug #1573755 and gave up, temporarily using an old 14.04.

But all my troubles under 16.04 disappeared abruptly last weekend after I configured the Compose Key as Shift-RightAlt. All my applications from vi to emacs to LibreOffice are now working perfectly. No other configuration gave me the same result. I do not know why, but hope that it can help. Regards Franco


I was having a very similar issue and for some reason what worked for me was putting all my custom compose key settings at the top of the original file all the way over in /usr/share/X11/locale/en_US.UTF-8/Compose and then making a hardlink to it called .XCompose in the home directory instead of writing my own .XCompose in the home directory from scratch. It worked for me, maybe it'll work for you.

  • 1
    That's an interesting observation; thanks for sharing! The en_US.UTF-8 Compose file is very large, possibly too large... – Gunnar Hjalmarsson Oct 16 '16 at 21:39

I had the same problem and solved it with these steps:

  1. Remove (or comment) any lines that deal with XIM configurations from your ~/.profile:

    # export GTK_IM_MODULE="xim"
    # export QT_IM_MODULE="xim"
    # export XMODIFIERS="@im=none"
  2. Set the input method "XIM" from the Language Support tool instead:

    Keyboard input method system: XIM

  3. Remove (or move) your ~/.config/dconf/user file (here's some info on what dconf is).

  4. Log out and log in again.

Thanks to Gunnar Hjalmarsson for pointing the bug #1573755 out. If this solutions doesn't work for you, you might find something useful in the thread.


Adding ibus-daemon --xim as a startup application fixes this for me. None of the other suggestions here worked.

Steps for doing this are:

  • Search for 'startup' using the Ubuntu search button on the toolbar (also accessible via the windows key). Select Startup Applications
  • Click the add button. In the dialogue that follows enter the following information:
  • Name = Ibus Daemon (or whatever)
  • Command = ibus-daemon --xim
  • Comment = whatever you like
  • Click Save
  • Log out and then back in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.