10

I've had my environment fonts set up a certain way for the past year or two to be significantly smaller and easier to read (for me) along with a bunch of other gui tweaks. Forgot a lot of the things I did to do it again, though.

After a software update on some applications last night, the font for a lot of things, but not everything, changed to a larger size. The only thing font-related that synaptic updated was fontconfig, fontconfig-config and related libs.

Basically, where do applications get their default font settings from and how can I configure them?

Although, I don't have a DE or gnome-settings-daemon running, I tried setting the options in gnome-tweak-tool, assuming it's a setting for GNOME/gtk applications, but it still didn't work. Tried looking for font-related settings in dconf-editor and gconf-editor as well.

I'm pretty sure I missed something since I've forgotten a lot of what I did to configure everything in the first place. For example, I checked my gtk2 and gtk3 settings as far as I can remember how they're set yet the settings still indicate the font and font size I've set since before.

Here's a list of some of the applications I've seen which had an increase in font size:

  1. gvim - I've only ever set the font and not the size in .vimrc, the size just increased from what it used to be.
  2. i3 - Like gvim above, I only set the font in .i3/config, so i3bar and the window title bar had the correct font, but got bigger after the update.
  3. evince - I first noticed it here. I was reading pdfs in presentation mode and noticed that the line "End of Presentation. Click to Exit" was bigger than it normally was. As usual, the font was still the correct one.
  4. dunst - Notification font got bigger. I don't remember ever setting the font manually for this program, but it used to have the correct font and size I set for the system a long time ago without having to manually set the application-specific font option for dunst.
  5. leafpad - Display font got bigger. Weird because I remember using it with the right size the week before.
  6. dmenu - Again, the font is the same as what I set it a long time ago. It's just bigger now.
  7. transmission-gtk - File list shown with Right Click > Properties shows each line to have an incorrectly scaled font. Fortunately, most of the rest of the application still has the correct font and font size I want.
  8. gnome-calculator - The font in the text box (the calculator "screen") is larger than normal.

Any information on how any of these applications set their fonts in the mentioned ways would help. Some of them share a clear common thread (being GTK/Gnome applications), but I'm thinking that further up the line, something common affected all of them in a similar way.

The fact that some of these applications have only ever had their font set, but not their font-size, tells me that the only thing that probably changed is whatever setting I changed a long time ago to set the font to be "smaller than default" got changed to a larger value. Again, I just can't remember or figure out where it's set.

EDIT: Unfortunately, I might have not been clear. The fonts themselves aren't the issue, but the size in which they are displayed by different applications. I've found the solution, which I've answered below.

4
  • 1
    I think you would increase the chances that someone tries to answer if you restrict the question to one or two specific applications instead of asking about applications in general. Aug 27, 2016 at 1:16
  • I considered that initially, but then I thought about allowing people with knowledge on different applications/application groups to provide their answers based on what they have a background in. That way, assuming that most common applications follow standards correctly and once good answers are provided, the different ways in which fonts are set in applications may be answered. Also, the fact that multiple applications were affected similarly leads me to assume that somewhere along the line, applications have a common thread when it comes to font display that was affected by the change.
    – maki57
    Aug 27, 2016 at 16:31
  • It's too broad with this state of the question. I fear I should vote it to close as such. There are many applications and each application can provide their own way of controlling font settings. Generally GTK applications follow Gtk font settings, but an application can have it's own settings
    – Anwar
    Sep 19, 2016 at 15:25
  • Vim most certainly does not get its default font from anything common with Leadpad. Are you sure that the font size increased in Vim? That is, in Vim, if you do :set guifont? you now see something different than what it was previously? Otherwise, I think that you have somehow increased the dpi setting of the display. What does xrandr say?
    – AlexP
    Jan 17, 2017 at 1:23

2 Answers 2

1

Regarding location of fonts, they are stored in /usr/share/fonts/ and /home/USERNAME/.fonts/. This may be somewhat relevant.

There is also a font section in the unity-tweak-tool for altering default font settings. Maybe give it a try.

1

The solution I've found is to edit the dpi settings in ~/.Xresources, by editing the line below to have the correct dpi value. The font now renders as it once did across multiple applications GTK or otherwise.

Xft.dpi: 96

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.