0

This question already has an answer here:

I'm using Ubuntu 16.04 LTS. I downloaded and installed Geogebra 5 as a deb package. Since then, whenever I do anything with apt, a message is displayed saying:

W: http://www.geogebra.net/linux/dists/stable/InRelease: Signature by key 98272894F6478AA4434B41D3C072A32983A736CF uses weak digest algorithm (SHA1)

I tried uninstalling Geogebra and purging its repository with ppa-purge (but this didn't work since I couldn't find the repository). There was no entry for Geogebra in my installed software list in GNOME (Ubuntu) Software even before I uninstalled.

How should I solve this? I am aware that this is a problem on Geogebra's server's end but since I don't need to use it anymore, I need a way to remove the repository. Thanks!

marked as duplicate by David Foerster, amc, Eric Carvalho, Pilot6, TheWanderer Nov 18 '16 at 11:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Open /etc/apt/sources.list and see if there are line(s) corresponding to Geogebra. If there are, comment out or delete them. – edwinksl Aug 21 '16 at 11:07
  • This should be fixed for now since GeoGebra 5.0.290.0. – Zoltán Kovács Nov 15 '16 at 14:10
0

The problem was solved by commenting out the contents of /etc/apt/sources.list.d/geogebra.list

  • 1
    You can also just rename or delete the .list file. – edwinksl Aug 21 '16 at 13:51
  • It was just a warning anyway so you could have ignored it and hope that the repository maintainer fixes the weak signature. – David Foerster Nov 15 '16 at 14:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.