I have tried to run Age of Empires 2 with wine using the virtual desktop feature to emulate a higher resolution screen. The game runs and the virtual desktop is indeed working, but it is running in a window and I can't find a way to make the virtual desktop fullscreen! This is a problem because the OS bar/launcher/etc are still visible/accessible/active, which leads to loss of screen real estate and trouble when moving the cursor left (the ubuntu launcher shows).

I'd like to know if anyone knows how to run the virtual desktop in proper fullscreen. I know I could hide the launcher and OS bar to "simulate" a fullscreen look but I'd rather have it be actually fullscreen.



On my system, I have two monitors, but this works with just one monitor as well. All I had to do was set the virtual desktop size to the same resolution as my monitor (1920x1080). Find your screen resolution and set that to be the virtual desktop size.

I play Rocket League on Steam and set full-screen mode in-game, and it works perfectly well. The panels on my system (as seen in the screenshot on top) do not interfere at all and aren't there.

| improve this answer | |
  • Thanks for your reply! I have tried that before and it is not working. The virtual desktop is simply running in a window of the same size of my screen. The OS elements are still visible though. Here is the wine configuration and here is how the game looks. Also, ticking the "allow window manager to control the window" results in the same thing. – Lucas Aug 21 '16 at 6:03
  • Okay, hmm. Because your settings menu is correct (fully blue, not showing any panels), try starting Age of Empires 2 in windowed without border mode. – Zzzach... Aug 21 '16 at 6:07
  • Do you mean disabling the virtual desktop (fourth box)? Or disabling window manager integration (second and third box)? Disabling window manager integration doesn't solve it. Disabling virtual desktop allows me to run it fullscreen, but I need to do it using the virtual desktop in order to simulate a different screen resolution. – Lucas Aug 21 '16 at 6:29
  • Keep the virtual desktop running, but in AoE2's settings, (game settings), change to windowed without border mode. When you opened the wine cfg settings, it was practically full screen, yes? So if you run AoE2 not in full screen mode but in "windowed without border", it will be full screen through the emulation. – Zzzach... Aug 22 '16 at 17:13
  • 2
    I kind of solved it!!! I installed the lxde environment and full screen there takes full effect. No system elements on sight and the game plays even better because of this. I don't know how to mark the problem as solved though. – Lucas Sep 4 '16 at 20:32

After some tweaking I managed to solve my problem. It seems this is a Unity related bug since the problem didn't persist under a different desktop.

To solve the issue I simply installed the lxde desktop environment and when I run the game there using the wine virtual desktop, no OS elements are visible so the full screen does work.

| improve this answer | |
  • Thanks! I also solved it (fullscreen for RollerCoaster Tycoon 2) by installing another desktop environment (gnome-session-flashback) and changing it from user login. This was on Ubuntu 16.04. – user1207958 Aug 28 '17 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.