1

I'm trying to make my Ubuntu 16.04.1 home server have (at least) two IPv6 addresses for its bonding interface of two physical network interfaces:

  1. A static local one from the fd:: range (for a Samba4 primary domain controller).
  2. A dynamic global one, acquired automatically, or assigned by the router (an AVM FritzBox 6360 in my case, from by my cable TV provider Unitymedia).

Of course it should still have a static local IPv4 address.

It used to work no problem about a year ago when I set up a different box, but I'm currently unable to reproduce that.

The problem is that my box does not learn the router's subnet (something in the 20a2:: range), but only has the configured static and an fe80:: address. How to change that? (Detail on my configuration below.)

I'm not intending to use network manager, but /etc/network/interfaces; here's what it currently looks like:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eno1
iface eno1 inet manual
    bond-master bond0
    mtu 4000

auto eno2
iface eno2 inet manual
    bond-master bond0
    mtu 4000

auto bond0
iface bond0 inet static
    address 192.168.1.10
    netmask 255.255.255.0
    gateway 192.168.1.1
    dns-nameservers 192.168.1.1
    mtu 4000
    bond-mode 0
    bond-slaves none
iface bond0 inet6 static
    address fdde:beda:1706:5326:dc::1
    gateway fdde:beda:1706:5326:a96:d7ff:fe58:3781
    dns-nameservers fdde:beda:1706:5326:a96:d7ff:fe58:3781
    netmask 64
    accept_ra 1
    autoconf 1
    mtu 4000
    bond-mode 0
    bond-slaves none

I have installed rdnssd as it is mentioned in the the manpage for the above file in the inet6 section, but I have not changed its default configuration. Here's the result of ifconfig after rebooting:

bond0 Link encap:Ethernet  Hardware Adresse 0c:c4:7a:80:39:86  
      inet Adresse:192.168.1.10  Bcast:192.168.1.255  Maske:255.255.255.0
      inet6-Adresse: fe80::ec4:7aff:fe80:3986/64 Gültigkeitsbereich:Verbindung
      inet6-Adresse: fdde:beda:1706:5326:dc::1/64 Gültigkeitsbereich:Global
      UP BROADCAST RUNNING MASTER MULTICAST  MTU:4000  Metrik:1
      RX-Pakete:1195 Fehler:0 Verloren:4 Überläufe:0 Fenster:0
      TX-Pakete:837 Fehler:0 Verloren:15 Überläufe:0 Träger:0
      Kollisionen:0 Sendewarteschlangenlänge:1000 
      RX-Bytes:134895 (134.8 KB)  TX-Bytes:120940 (120.9 KB)

eno1  Link encap:Ethernet  Hardware Adresse 0c:c4:7a:80:39:86  
      UP BROADCAST RUNNING SLAVE MULTICAST  MTU:4000  Metrik:1
      RX-Pakete:613 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
      TX-Pakete:466 Fehler:0 Verloren:0 Überläufe:0 Träger:0
      Kollisionen:0 Sendewarteschlangenlänge:1000 
      RX-Bytes:71702 (71.7 KB)  TX-Bytes:64530 (64.5 KB)
      Interrupt:16 Speicher:df300000-df320000 

eno2  Link encap:Ethernet  Hardware Adresse 0c:c4:7a:80:39:86  
      UP BROADCAST RUNNING SLAVE MULTICAST  MTU:4000  Metrik:1
      RX-Pakete:582 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
      TX-Pakete:371 Fehler:0 Verloren:0 Überläufe:0 Träger:0
      Kollisionen:0 Sendewarteschlangenlänge:1000 
      RX-Bytes:63193 (63.1 KB)  TX-Bytes:56410 (56.4 KB)
      Speicher:df100000-df17ffff 

lo    Link encap:Lokale Schleife  
      inet Adresse:127.0.0.1  Maske:255.0.0.0
      inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
      UP LOOPBACK RUNNING  MTU:65536  Metrik:1
      RX-Pakete:172 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
      TX-Pakete:172 Fehler:0 Verloren:0 Überläufe:0 Träger:0
      Kollisionen:0 Sendewarteschlangenlänge:1 
      RX-Bytes:12560 (12.5 KB)  TX-Bytes:12560 (12.5 KB)

Sorry for the german content, but I guess that if you know ifconfig's output, you can still get the relevant information.

My router is currently configured to just assign DNS name server's via DHCPv6, but can as well by configured to additionally assign a prefix (IA_PD), and furthermore an IPv6 address (IA_NA). I've tested all three options - none of them had a recognizable effect.

  • I've just figured out that the inet6config seems to be ok - it works as soon as the inet (IPv4) config is set to dhcp instead of static. However, I want both (IPv4 and v6) addresses to be static... – Gunnar Arndt Aug 21 '16 at 18:16
0

What can I say? The above configuration seems to be correct, it works now although I haven't changed anything...who said that computers were deterministic?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.