0

I want to upgrade Ubuntu 14.04.3 LTS to Ubuntu 16.04 LTS.

First I run

sudo apt update
sudo apt dist-upgrade

Then I checked Ubuntu running version:

cat /etc/lsb-release

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.3 LTS"

and then I started Ubuntu 16.04 installation with

sudo do-release-upgrade -d

which threw the following error:

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed. 

I know that first I need to upgrade Ubuntu 14.04.3 LTS to Ubuntu 14.04.4 LTS and then to Ubuntu 16.04 LTS. But unable to upgrade Ubuntu 14.04.3 LTS to Ubuntu 14.04.4 LTS. I would highly appreciate if someone help me in this regard. Thanks

I tried:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install
sudo apt-get -y install apt
sudo do-release-upgrade

But still getting the same error. Any help will be highly appreciated. Thanks

8
  • Waow.I didn't know about this method.I thought the upgrade will only be done when the software updater states that a new version of ubuntu is ready.. – john400 Aug 20 '16 at 6:04
  • Thanks @Anwar for pointing to a solution. But still I'm getting the same error. Please see my edits and suggest any solution if you can. Thanks – MYaseen208 Aug 20 '16 at 6:39
  • Have you tried the solutions there? – Anwar Aug 20 '16 at 7:01
  • Yes, @Anwar. I tried the solution given in the link but still getting the same error. Any thoughts, please. Thanks – MYaseen208 Aug 20 '16 at 7:45
  • 2
    Check this question and it's solution. It will be solved. Make sure you first upgraded to 14.04.4 using sudo apt-get dist-upgrade. Then do the do-release-upgrade – Anwar Aug 22 '16 at 14:31

Browse other questions tagged or ask your own question.