2

I installed Ubuntu16.04 LTS in Acer-Aspire 5742 laptop. Every thing running well but wifi always hard blocked after 10-15 min.

  1. I tried to add acer_wmi, wmi, wl to blacklist /etc/modprobe.d/blacklist.conf
  2. I also tried to unblock using sudo rfkill unblock all but did not help.
  3. I am ensure wifi is enabled by hardware.

I read multiple threads but no one help me.

Out put of command : lspci -knn | grep Net -A2

01:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe [14e4:1692] (rev 01)
    Subsystem: Acer Incorporated [ALI] NetLink BCM57780 Gigabit Ethernet PCIe [1025:036d]
    Kernel driver in use: tg3
    Kernel modules: tg3
02:00.0 Network controller [0280]: Broadcom Corporation BCM43225 802.11b/g/n [14e4:4357] (rev 01)
    Subsystem: Foxconn International, Inc. T77H103.00 Wireless Half-size Mini PCIe Card [105b:e021]
    Kernel driver in use: bcma-pci-bridge
  • Is the wifi getting disconnected constantly? – john400 Aug 20 '16 at 7:17
  • No, when I start , wifi connected properly and working fine . But after 10-15 minute automatically disconnected and I see wifi is blocked by hardware and then unable to connect. – umesh kushwaha Aug 20 '16 at 8:14
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Aug 20 '16 at 10:38
  • Try to install the proprietary driver sudo apt install bcmwl-kernel-source. This driver claims to support this adapter. Secure Boot should be disabled if UEFI is used. – Pilot6 Aug 20 '16 at 12:31
  • acer aspire 5742 does not have secure boot option – umesh kushwaha Aug 20 '16 at 13:05
0

You can try to reactivate your wifi by using

sudo rfkill unblock wifi
| improve this answer | |
  • in question i mention already used, it did not help – umesh kushwaha Aug 20 '16 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.