0

I've encountered some weird behavior. Just upgraded from Ubuntu 12.04 to 16.04. During the first restart, the little splash window of orange-white dots hangs forever and then fails to a command line. I tried all of the various options available and then I noticed the label for my external HDD was mentioned at one point in some of the text going by so I plugged it back in and immediately, the machine started up again...

The external HDD was NOT plugged in when the upgrade was installed.

Any clues about how to fix this problem. It's a hassle because I share this HDD with other folks and I don't want to always have it with me.

===info requested by Al. Thanks for your help!

sudo blkid

/dev/sda1: LABEL="SYSTEM_DRV" UUID="A2F4028AF40260C1" TYPE="ntfs" PARTUUID="cf479f9e-01" /dev/sda2: LABEL="Windows7_OS" UUID="FE980B0E980AC4DD" TYPE="ntfs" PARTUUID="cf479f9e-02" /dev/sda4: LABEL="Lenovo_Recovery" UUID="BC2E01E12E019614" TYPE="ntfs" PARTUUID="cf479f9e-04" /dev/sda5: LABEL="New Volume" UUID="66F8DF30F8DEFCED" TYPE="ntfs" PARTUUID="cf479f9e-05" /dev/sda6: UUID="c7d3764e-d769-427b-8525-3ddb2b868e1e" TYPE="ext4" PARTUUID="cf479f9e-06" /dev/sda7: UUID="d4da275c-f316-4067-a31f-c9cd86cb053f" TYPE="swap" PARTUUID="cf479f9e-07" /dev/sdb1: LABEL="mta1" UUID="4E1AEA7B1AEA6007" TYPE="ntfs" PARTUUID="40e7640c-01"

more /etc/fstab

Entry for /dev/sda6 :

UUID=c7d3764e-d769-427b-8525-3ddb2b868e1e / ext4 errors=remount-r o 0 1

Entry for /dev/sda4 :

UUID=BC2E01E12E019614 /media/Lenovo_Recovery ntfs-3g defaults,locale=en_US.UT F-8 0 0

Entry for /dev/sda1 :

UUID=A2F4028AF40260C1 /media/SYSTEM_DRV ntfs-3g defaults,locale=en_US.UT F-8 0 0

Entry for /dev/sda2 :

UUID=FE980B0E980AC4DD /media/Windows7_OS ntfs-3g defaults,locale=en_US.UT F-8 0 0

Entry for /dev/sda5 :

UUID=66F8DF30F8DEFCED /media/chuckcannon/New\040Volume ntfs defaults ,nosuid,nodev,uhelper=udisks2,uid=1001,gid=1001,dmask=0077,fmask=0177 0
0

Entry for /dev/sdb1 :

UUID=4E1AEA7B1AEA6007 /media/chuckcannon/mta1 ntfs defaults,nosuid,nodev,uh elper=udisks2,uid=1001,gid=1001,dmask=0077,fmask=0177 0 0

Entry for /dev/sda7 :

  • Did you add a mount for the external drive into your /etc/fstab? Please go to terminal and get the output of "sudo blkid" (have the external drive connected), and "more /etc/fstab" and post it here. Cheers, Al – heynnema Aug 20 '16 at 1:33
  • Al, I posted the output from those commands. Thanks for your help. – Chuck Cannon Aug 21 '16 at 21:56
  • Wow. OK. You don't need to mount sda1 and sda4, so remove those. If you're going to mount sda2, you need to make sure that FAST BOOT and HIBERNATION are turned off in Windows. Why the (possibly) over-complex mounts for sda5 and sdb1? If you're going to mount sdb1 via fstab, then you'll need to have the external drive connected at all times. If however, you remove this mount, then when you connect the external drive, if it doesn't automatically mount, you can manually mount it by clicking on its name in the left pane of a Nautilus file manager window. Cheers, Al – heynnema Aug 21 '16 at 22:24
  • actually I inherited this machine from someone else who installed Ubuntu and I've toyed with completely wiping it because I didn't understand how they complicated things so much. I'm not a newb but I don't often have time to dig into the details, so I've let it go for now. ...and I took a several year break from Ubuntu, so just now getting back into it. thanks for the advice, I'll try and follow up on it when I can. – Chuck Cannon Aug 23 '16 at 17:09
0

As per our discussion above...

You don't need to mount sda1 and sda4, so remove those. If you're going to mount sda2, you need to make sure that FAST BOOT and HIBERNATION are turned off in Windows. Why the (possibly) over-complex mounts for sda5 and sdb1?

If you're going to mount sdb1 via fstab, then you'll need to have the external drive connected at all times. If however, you remove this mount, then when you connect the external drive, if it doesn't automatically mount, you can manually mount it by clicking on its name in the left pane of a Nautilus file manager window.

Glad you got it going! Cheers, Al

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.