I'm using a laptop with Windows 10 and my plan was mounting Ubuntu's ISO on a USB, booting from that USB and installing Ubuntu on an external HDD so I can use it without having it inside my laptop.

So, I downloaded the ISO 16.04.1 desktop, downloaded Rufus and proceeded with the official guide, step by step.

Result: Mounting the ISO failed, I got an "Error while partitioning drive" and this showed up:

enter image description here

Now, my USB doesn't even work. When I plug it, Windows prompts me to format it. Formatting fails, Windows disconnects the USB.

Is there any way to solve this so I can try again mounting the ISO to discover Ubuntu or is my USB totally unrecoverable?

  • I'm sorry, but it's very unlikely that this was caused by the Ubuntu ISO, and much more likely that it's because of Windows or your hardware. Because of that, this question is off-topic here. However, Super User may get you an answer. Aug 19, 2016 at 21:23
  • My USB drive worked perfectly, how a USB drive is supposed to work 5min before trying to mount the ISO, so yeah, it was mounting the ISO what caused this.
    – alvafu
    Aug 19, 2016 at 21:33
  • yes, burning the ISO caused it, but not the ISO. Even if it was the ISO, this has nothing to do with Ubuntu. Aug 19, 2016 at 21:40

2 Answers 2


Cooler heads should prevail... reboot your computer, and the USB port will probably be fine. Prove it by plugging in a DIFFERENT USB device.

My experience is that building a USB flash drive is very unreliable, no matter how it's done. Burn your .ISO to a DVD, and then boot the DVD to install Ubuntu. It'll work fine.

While you're in Ubuntu, trying formatting the suspect USB flash drive, and it too, will probably work fine.

  • Rebooted laptop, tried other 2 USBs and 2 external HDDs. All four work fine as always. Tried the problematic USB, still broken. I searched how to fix it from raw back to a ntfs of fat format and while people on youtube show how it works for them, when I do the same the USB disconnects and stops being recognized. I guess that's its end. And I don't have at this moment dvds to burn so installing Ubuntu on my external HDD will have to wait. Thanks for your answer though, +1 to you
    – alvafu
    Aug 19, 2016 at 23:43
  • Glad your USB is working again. Please vote, or accept, my answer, if you can. Cheers, Al
    – heynnema
    Aug 19, 2016 at 23:48
  • My USB isn't working, I said it's still broken. I haven't found a way to fix it so I'll try with DVDs. I'd rather dump a dvd into the trash than another USB drive. Thanks.
    – alvafu
    Aug 20, 2016 at 13:50
  • Do you mean your USB flash drive isn't working, or your USB ports aren't working? I thought that the reboot fixed the ports problem. Please clarify. Cheers, Al
    – heynnema
    Aug 20, 2016 at 14:30
  • The USB Flash drive is dead. Ports work fine, other USB drives and external HDDs I have work fine. It's just the USB drive I used to mount the ISO. Tried everything: formatting, renaming its letter, seen tutorial on how to fix... It's in RAW state and can't get it back to an usable format. But thanks, though. At this point I think it's easier to buy a new one.
    – alvafu
    Aug 20, 2016 at 19:03

Retry making a bootable USB with pendrive. http://www.pendrivelinux.com/

I had issues with RUFUS as well. I found I never had issues with pendrive.

Not the answer you're looking for? Browse other questions tagged or ask your own question.