0

I am trying to control my screen's backlight using xbacklight. I have intel HD graphics 530 (skylake) disabled, and nvidia gtx960M on. (proprietary nvidia-361 driver active)

xbacklight has no effect when my nvidia card is enabled. And in fact, /sys/class/backlight only contains an intel_backlight folder (from which I can change brightness by modifying the value set in the "brightness" folder, even though intel card is disabled)

I tried different solutions found on other posts: - kernel flags like acpi_osi=Linux acpi_backlight=vendor/native/... video.use_native_backlight=1, etc. - Xorg conf file modification ("RegistryDwords" "EnableBrightnessControl=1") - I also tried using redshift to control brightness, with no more success than xbacklight.

I would keep modifying brightness directly from the /sys/class/backlight/brightness file if I didn't experience issues with the saving of the value (which is comprised between 0 and 937..) which sometimes set brightness to 0 even though I specified normal values (like 500..).

Do you know if there is a solution to this problem?

Thanks in advance for your answers =)

0

I had the same problem.

I had Intel and NVidia cards and whenever I switch to NVidia's propriety driver nvidia-381 using nvidia-prime, xbacklight didn't work.

Finally I have 2 solutions which allows changing brightness no matter which graphics card or driver you are using.

1st solution: Commandline solution

First, use this command to get max brightness:/usr/lib/gnome-settings-daemon/gsd-backlight-helper --get-max-brightness. Say it gives value y.

Second, use this command to set brightness(requires sudo): sudo /usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness x.

Replace x with any value between 0 to y.

I have tested it on Ubuntu 14.04. Might not work on Kubuntu.

NOTES:

  1. Don't try to use 0 in x, you will get a blank screen aka screen with no brightness (Yes, you can type on blank screen in this case).

  2. If you don't want to use sudo everytime in 2nd command then type sudo visudo and append %VAR_USER ALL = NOPASSWD: /usr/lib/gnome-settings-daemon/gsd-backlight-helper to sudoers list. (Change VAR_USER to your username).

Warning: Be careful when you edit sudoers list if you are not experienced user then don't do it.

2nd solution: Graphical solution

Install indicator-brightness package using below commands(Please look at this answer for more elaborate steps):

sudo add-apt-repository ppa:indicator-brightness/ppa
sudo apt-get update
sudo apt-get install indicator-brightness

Add it to startup applications if you don't have its entry as shown below.

enter image description here

enter image description here

enter image description here

It is worth noting that indicator-brightness uses same commands found in 1st solution but as daemon.

Also, 1st solution can be used to set brightness on virtual consoles accessed via Ctrl+Alt+F1 to Ctrl+Alt+F6.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.