3

I'm trying to setup guest virtual machines using virtual Box on a headless ubuntu server using VBoxManage. I have the guest machines running the only issue is with the networking.

Here is the command I used to setup the adapter: enp2s7 is my Ethernet adapter VBoxManage modifyvm "UbuntuServer" --nic1 bridged --bridgeadapter1 enp2s7

I have installed bridge utils on the host machine also as I thought that was needed.

Here is another thing that I have tried: Edited on the host machine: /etc/network/innterfaces

source /etc/network/interfaces.d/*

auto lo

iface lo inet loopback

The primary network interface

auto br0

iface br0 inet static
address 192.168.1.2
netmask 255.255.255.0
network 192.168.1.0
gateway 192.168.1.1
dns-nameservers 192.168.1.1
bridge_ports enp2s7
bridge_fd 0
bridge_hello 2
bridge_maxage 0
bridge_stp off

Then I updated the VM to the following and still it won't connect.

VBoxManage modifyvm "UbuntuServer" --nic1 bridged --bridgeadapter1 br0

This usually pops up during install and even after install I tried to manually configure the interfaces on the Virtual Machine Guest system. The guest system does recognize the adapter however it still does not work using both dhcp and static ip.

Any help is appreciated!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.