I have a Canon LiDE 120 scanner connected to a Ubuntu 16.4 box. The scanner is detected, but the produced images are completely black.

More precisely, if I press "scan" or "preview" in xsane, there is a short initial noise from the scanner motor, then nothing is happening for about half a minute, then the scan is performed (lamp on) and the resulting image is black. Scanning from the command line with scanimage, the behavior is exactly the same (including delay). The scanner does work on Windows, so the hardware should be fine. Using the Color picker tool in Gimp a few times, I checked that the color is totally black (all color values equal 0).

Maybe the delay for half a minute is somehow connected to the problem? (Could be some sort of a timeout)

The picture from searching for this problem is not completely clear: First, Sane support for the Canon LiDE 120 was problematic at least till 14.04. Apparently a few setups on 16.04 are running flawlessly, others seem to have the same problem. As a source of errors it was reported that the lock switch at the lower surface of the scanner has to be unlocked (this is the case, I also tried lock-unlock-restart) and USB ports behind an external USB hub (scanner is directly connected, I tried different USB ports).

From lsusb:

Bus 001 Device 004: ID 04a9:190e Canon, Inc.


scanimage -L

device `genesys:libusb:001:004' is a Canon LiDE 120 flatbed scanner

6 Answers 6


as from the reply from pavel,

$ sudo add-apt-repository ppa:rolfbensch/sane-git

then run

$ sudo apt update

If you do not have sane and all its libraries installed then install it by executing the following.

$ sudo apt -y install sane libsane libsane-common sane-utils libsane-extras

should make it work.

I have also followed the same instructions and it worked. :)


So I had this, and I tried the package from the PPA above and I was still getting black scans. Ugh! Then I was looking through man sane-genesys which is the backend for this scanner and noticed the calibration settings. I then ran this:

$ scanimage --clear-calibration > foo.pnm

That caused a little back and forth, and then the scanner works great!


I can confirm this issue, having tested two CanoScan LiDE 120 scanners. It looks like sooner or later, the scanner ends in a state where it is no longer functioning properly.

In my opinion, either the authors of the genesys backend should look into this, or the scanner should be removed from the list of linux-compatible scanners.

  • Yes, I have the same problem with 18.04. The LiDe 220 work without issues.
    – Andor Kiss
    Mar 19, 2019 at 2:41

On the bottom of Cannon Lide is a lock switch. please be sure you have unlocked the switch or it will click and then lock in place and cause blank pages. Look on Lide 220 as well.


For me the problem was the USB power supply. After connecting the scanner diretcly to the USB port of my computer, it worked. I found the solution through this link (https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/996741).

  • Glad it worked for you ... I have a similar problem (brand-new Canon LiDE 120, produces completely black scans), I've tried multiple USB ports on the intended computer (a ThinkCenter m91p), and multiple USB ports on another computer, tried the provided cable and a similar cable from a broken LiDE 220, none of them help. Note that Canon support currently lists "Linux" in the table of "incompatible operating systems" for this device.
    – david
    Jan 3, 2018 at 14:56

I've had the same problem since 16.04 LTS was released. I came across this commercial software, specifically for LiDE120 (N670U) Canon scanners. It's $29.95 and works! Multiple pages without the black screen issue. I've bought it as my scanner is perfectly working and just needed software. The software is called "VueScan": https://www.hamrick.com/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.