1

I am affraid this is either a duplicate or a hard to explain situation, will see.

I have a remote legacy system runnng on 'old' xwindow sytem with a 'old' vnc server on it. in there I goet a xemacs running well since hum decades. The xemacs is setup so that Shift_L+Button1 Control_L+Button1 Alt_L+Button all are mapped to xemacs function, and all that works, either locally, or through man other dsitro linux version vnclient to this vncserver. Working correctly mean that all my vnclient do send whatever it takes to get those Modifier+Button1 working

Now on 1 node I isntalled to ubuntu server 16.04 and installed xfce4.

On xfce4 I got all possible keyboard shortcut I know ( I may miss some?) to not use any short cut.

Settings->Keyboard->Application Shortcuts is empty

Settings->Keyboard->Layout is System default ( I tested gebneric 101-key PC with no fix)

Settings->Window manager->Keyboard Cleared all

Settings->Window Manager Tweaks->Accessibility->Key to grab and move window-> NONE

I tried to remove every shortcut that could intercep shift/alt/ctrl modifiers.

Then I checked my xserver with xev and see this

Alt_L+Button1 KeyPress event, serial 33, synthetic NO, window 0x2800001, root 0x49f, subw 0x0, time 7015251, (14,146), root:(885,667), state 0x0, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES, XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False

ButtonPress event, serial 36, synthetic NO, window 0x2800001,
    root 0x49f, subw 0x0, time 7016124, (14,146), root:(885,667),
    state 0x8, button 1, same_screen YES

ButtonRelease event, serial 36, synthetic NO, window 0x2800001,
    root 0x49f, subw 0x0, time 7017228, (14,146), root:(885,667),
    state 0x108, button 1, same_screen YES

KeyRelease event, serial 36, synthetic NO, window 0x2800001,
    root 0x49f, subw 0x0, time 7017843, (14,146), root:(885,667),
    state 0x8, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Control_L+Button1 KeyPress event, serial 36, synthetic NO, window 0x2800001, root 0x49f, subw 0x0, time 7093556, (5,153), root:(937,652), state 0x0, keycode 37 (keysym 0xffe3, Control_L), same_screen YES, XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False

ButtonPress event, serial 36, synthetic NO, window 0x2800001,
    root 0x49f, subw 0x0, time 7094508, (5,153), root:(937,652),
    state 0x4, button 1, same_screen YES

ButtonRelease event, serial 36, synthetic NO, window 0x2800001,
    root 0x49f, subw 0x0, time 7095420, (5,153), root:(937,652),
    state 0x104, button 1, same_screen YES

KeyRelease event, serial 36, synthetic NO, window 0x2800001,
    root 0x49f, subw 0x0, time 7096076, (5,153), root:(937,652),
    state 0x4, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

My modifiers Tc$ xmodmap -pm xmodmap: up to 4 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock      
control     Control_L (0x25),  Control_L (0x42),  Control_R (0x69)
mod1        Alt_L (0x40),  Alt_R (0x6c),  Meta_L (0xcd)
mod2      
mod3      
mod4        Super_L (0x85),  Super_R (0x86),  Super_L (0xce),  Hyper_L (0xcf)
mod5        ISO_Level3_Shift (0x5c),  Mode_switch (0xcb)

When doing xvncviewer to my legacy x11 server using xemacs, doing i.e decrive-key and when doing + xemacs receive only the no modifiers.

Since the remote vncservers works fine form other client, I cors it out (beside it works since decades).

Since all my other vnclient (unbuntu 14.04, debian, redhat) works fine I cross them out.

Only this ubuntu 16.04 + xfce4 seems to be a problems.

Dunno what to look next.

Cheers, Phi

  • Using gnome-flashback don't have this problem so switching back to gnome, already missing xfce – Phi Aug 22 '16 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.