2

OBS crashes (segfault) when I tap the trackpad while the mouse is over the OBS window. Using the mouse does not cause this crash.

The guy on this forum post ran into issues with OBS, specifically mouse and crashing issues.

My installation ran into the same problem running on an XPS 13, x64 Ubuntu 14.04.5 LTS.

[1]    17198 segmentation fault (core dumped)  obs

Here is the output of gdb ods... seems to be a qt5 problem.

Program received signal SIGSEGV, Segmentation fault.
0x00007fffda837cbb in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so

Additional info

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

OBS studio was installed using apt-get install obs-studio.

$ sudo apt-cache policy obs-studio libqt5gui5
obs-studio:
  Installed: 0.16.2.1-544~trusty
  Candidate: 0.16.2.1-544~trusty
  Version table:
 *** 0.16.2.1-544~trusty 0
        500 http://ppa.launchpad.net/obsproject/obs-studio/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5gui5:
  Installed: 5.2.1+dfsg-1ubuntu14.3
  Candidate: 5.2.1+dfsg-1ubuntu14.3
  Version table:
 *** 5.2.1+dfsg-1ubuntu14.3 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status
     5.2.1+dfsg-1ubuntu14 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

closed as off-topic by user.dz, WinEunuuchs2Unix, David Foerster, TheWanderer, Zanna Dec 28 '16 at 8:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – user.dz, WinEunuuchs2Unix, David Foerster, TheWanderer, Zanna
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Could you edit the question and add how you installed it, plus the output of apt-cache policy obs-studio libqt5gui5 – user.dz Dec 13 '16 at 19:17
  • okay, edited post to include this information – Jamie Dec 15 '16 at 15:58
1
+50

That was same version used to build the obs, here is the related build log. You better go with bug report against obs.

But before reporting, test the last unstable build from OBS Studio Unstable PPA

sudo apt-add-repository ppa:obsproject/obs-studio-unstable
sudo apt-get update
sudo apt-get install obs-studio

The Linux version of OBS is still under development and contains many bugs, but if you're feeling brave, and can install Ubuntu PPAs, then you can give this a try.

Source: OBS Project, Ubuntu PPA Installation Instructions

  • Tried the workaround, same problem. Maybe there is a workaround for the qt5 component because that seems to be causing the crash? – Jamie Dec 16 '16 at 17:27
  • @Jamie, you may try the last Qt 5.7.1 from qt.io/download-open-source/#section-2 . See here how to set as default askubuntu.com/questions/435564/… . Qt team says that they try to keep backward compatibility, however if it fails, we may try to rebuild/recompile obs vs Qt 5.7.1 (up to you to take this adventure :-) ) – user.dz Dec 16 '16 at 19:03
  • @Jamie, any results with last Qt? – user.dz Dec 17 '16 at 21:12
  • 1
    The problem seems solved, but I'm not sure how. I installed QT 5.7.1 to a local folder but did not make it the default. When I ran qtchooser -print-env, I noticed that the default version of QT was 4.x. Then I ran obs -qt=5, which worked (no crashes), and after that, running obs normally without the flag runs without crashing. All in all I'm not sure what fixed the issue. – Jamie Dec 17 '16 at 21:33
  • 1
    If only! I believe the -qt flag was a red herring, the flag has no effect. obs -qt=4also does not crash, and neither does any bad value for the flag. In addition moving the local installation of Qt has no effect. I am not sure how to reproduce the problem. – Jamie Dec 17 '16 at 21:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.