0

I am using Ubuntu 16.04 on a laptop Dell XPS 15 9550. Current kernel is 4.4.0-34. Display resolution is 3840x2160. I am using nvidia prime and currently the nvidia driver 370, but I select "Intel" in the prime-indicator by default. I don't know what other information is relevant, please feel free to ask.

My system is mostly working but there are a few issues:

  • Sometimes (most times) Ubuntu takes a long while to shut down, don't know why.
  • Sometimes when I edit a text file (say in gedit text editor), my system "doesn't like it", it seems to be lagging for no reason.
  • Some programs often crash (Firefox for instance)
  • Sometimes I get error messages "System program error detected".

None of these problems are so frustrating that I really tried to do something about it. But recently I starting working again on a Qt/C++ project using Qt Creator, and Qt Creator crashes all the time, making it unusable. Here is what happens: as soon as I start editing a file such as main.cpp in Qt Creator, it crashes. If I run it from the terminal with strace, all I can read is:

--- SIGSEGV {si_signo=SIGSEGV, si_code=SI_KERNEL, si_addr=0} ---
+++ killed by SIGSEGV (core dumped) +++
Segmentation fault (core dumped)

At first I thought something may be wrong with my Qt Creator, but now I think the fault is on Ubuntu (I have tried several versions of Qt Creator, several install methods, all produce the same effect). Although I have no clue what is going on, I suspect maybe the problem is related to the graphics driver? As well as my other issues described above?

If you could help me with this, it'd be great.

  • Did you find a solution for this? – ulitosCoder Feb 22 '18 at 19:14
1

I had the same problem with QtCreator on the same machine model. At first, I also looked for the graphics drivers, but I noticed that Qt worked perfectly when run with sudo.

So I searched in environment variables, and I noticed that QtCreator works when QT_LINUX_ACCESSIBILITY_ALWAYS_ON is not set. I think this setting forces the screen reader to read the code, which Qt does not like.

After searching, I found a script /etc/X11/Xsession.d/90qt-a11y that export this variable on session opening. Simply commenting on this line and restarting the session solved the problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.