3

I am having problems getting my wireless adapter (TP-Link WDN3200) to function on a fresh install of Ubuntu. Right now I have internet as I connected through ethernet in a different part of the building but in my room wireless is my only option. I simply CANNOT connect to hidden network that operates in our home. All other devices that I've used connect to it without a problem using the same PW and security details, including this computer with a Windows 7 install. I am at a loss. For now I shall leave some of the details I've picked up on while troubleshooting this problem.

Quick rundown of the main issues -

  1. Wireless adapter gets very hot even when idle.
  2. Hidden network profile displays "Out of Range" in Network Manager
  3. I can see other networks being detected by the device in Ubuntu.
  4. If I use any of the iwconfig commands to override the adapter settings, the terminal returns the message "Device or resource busy."

Ps. I suspect it has something to do with the Dual Band settings of the adapter. I had similar issues on my Windows install and until I found proper drivers I was unable to connect and experienced the same heating up of the adapter. If there is a way to force 2.4Ghz on Ubuntu that may solve it as I had to do that on Windows.

I am all ears from this point! As this location isn't the most suitable for internet access I will try to get back to replies not more than a day later.

lsmod
    rt2800usb              28672  0
rt2x00usb              20480  1 rt2800usb
rt2800lib              90112  1 rt2800usb
rt2x00lib              49152  3 rt2x00usb,rt2800lib,rt2800usb
crc_ccitt              16384  1 rt2800lib
nls_utf8               16384  1
isofs                  40960  1
rtl8xxxu               69632  0
arc4                   16384  0
rtl8192cu              65536  0
rtl_usb                20480  1 rtl8192cu
rtl8192c_common        49152  1 rtl8192cu
rtlwifi                69632  3 rtl_usb,rtl8192c_common,rtl8192cu
mac80211              659456  7 rtl8xxxu,rtl_usb,rtlwifi,rt2x00lib,rt2x00usb,rt2800lib,rtl8192cu
cfg80211              499712  3 mac80211,rtlwifi,rt2x00lib

sudo lshw -C network
  *-network               
       description: Wireless interface
       physical id: 1
       bus info: usb@1:7
       logical name: wlx647002279cb2
       serial: 64:70:02:27:9c:b2
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=4.4.0-31-generic firmware=0.29 link=no multicast=yes wireless=IEEE 802.11abgn

sudo iwconfig
wlx647002279cb2  IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

lo        no wireless extensions.

enp0s18   no wireless extensions.

rfkill list all
5: phy5: Wireless LAN
    Soft blocked: no
    Hard blocked: no

lsusb
72 Ralink Technology, Corp. RT5572 Wireless Adapter

Additionally here is a pastebin link with all of this info and more as suggested by the website. http://pastebin.com/LXcvEVnw

1

You have three (!!!) wireless drivers loaded. I suggest that we unload the two that are not relevant. Please open a terminal and run:

sudo modprobe -r rtl8192cu
sudo modprobe -r rtl8xxxu

Reboot. Did they somehow load automatically anyway? If so, we'll blacklist them. CAUTION: Do not undertake this step unless its required because the drivers reloaded.

sudo -i
echo "blacklist rtl8192cu"  >>  /etc/modprobe.d/blacklist.conf
echo "blacklist rtl8xxxu"  >>  /etc/modprobe.d/blacklist.conf
exit

I suspect that you tried some other USB wireless with an rtl8192cu chipset that also didn't work well because too many drivers loaded.

Finally, I suggest that you turn off wireless N in your router. I have seen and worked on several cases where 802.11N made rt2800xxx devices throw errors and fail to connect. Please set your router to use Auto B and G but not N.

  • Thanks for your advice, good spot there on the extra drivers. I successfully removed the drivers that you specified but it has not changed the situation in connectivity. I should have probably mentioned (my mistake) that I do not have administrative rights to the router so that is not an option I can take. In the meantime I used sudo-apt-get upgrade in hopes of perhaps installing a critical file that was missing on the default ISO but again it came to no avail. For now I'm exploring alternative software to the default Network Manager but again I'm open to more suggestions. – Alex Aug 19 '16 at 17:38
  • Of course, one alternative is to blacklist rt2800usb and try the rtl8192cu device again, leaving rtl8xxxu blacklisted. I really doubt that if rt2800usb is throwing out dozens of errors, changing from NM to Wicd or any other manager will change it. – chili555 Aug 19 '16 at 18:05
  • Thanks, I'll try the second adapter on hand with the blacklisting method and update on how it goes. That said dmesg is still showing rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0404 with error -71 en masse so I suppose that is another issue that needs resolving altogether. I was able to install wicd after a few hiccups and miraculously the program sees the hidden network. I still can't connect to it (Bad password error) but this is getting offtopic so for now I'll stick to blacklisting the drivers and trying again with the other adapter. Thanks again! – Alex Aug 19 '16 at 19:52
  • Update - After much trouble messing with the 2800 chipset adapter it was a hardware issue in the end that prevented Network-Manager from functioning. I removed wicd and re-installed NM, this time trying the rtlrtl8192cu chipset with no excess drivers and I am connected without a hitch! Thanks for sticking through the troubleshooting process and thank you for all of your advice chili555 :) – Alex Aug 21 '16 at 4:43
1

Hardware issue with the rt2800 chipset. After reverting back to network manager and checking that only rtl8192cu device drivers were loaded, the wifi connected without any issues. For those that are curious my two adapters were the TP-Link WDN3200 (rt2800 chipset) and the TL-WN823N (rtl8192cu chipset). Lesson learned here, hardware is key sometimes!

EDIT - Something bizarre just happened, once I removed the package wicd-daemon my wireless internet promptly cut out. Once I restored it, it began working again. So to go through the steps I took solving this I:

  1. Installed Network-Manager (sudo apt-get install network-manager)
  2. Installed wicd (sudo apt-get install wicd-daemon)
  3. Connected through network manager with my SSID and password credentials.

My hidden network profile worked correctly both through "Edit Connections" and "Connect to Hidden-Wi-Fi Network".

Truly an unorthodox mode of operating with errors being thrown upon boot, but at the very least it is working :o

EDIT 2 - After messing up my install I reformatted with a new Ubuntu 16.04 partition. Turns out it was purely a hardware issue with the first adapter, as I was able to connect to my network through the "Connect to Hidden Wi-Fi Network" option using the rtl8192cu hardware without downloading or installing any additional software. Connecting through a profile still didn't work but creating it does help in saving your connection info once you are online.

This question is effectively solved and in retrospect it's incredible how such a simple fix messed with my head for so long!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.