0

there, like for others, the desktop is not loading past the logging part. After i put the password appears the desktop background, the mouse cursor and the box with xfce saying desktop starting blabla the usual but then the desktop doesn t load further. same for other accounts and recovery mode.

tried so far:

  • export DISPLAY=:0
  • sudo dconf reset -f /org/compiz/ setsid unity
  • enable Unity using ccsm
  • installed and uninstalled nvidia
  • installed and reinstalled settings, startup
  • update and upgraded the computer
  • sudo apt-get install --reinstall compiz
  • sudo apt-get install --reinstall ubuntu-desktop unity compizconfig-settings-manager upstart
  • sudo rm -fr ~/.cache/compizconfig-1 sudo rm -fr ~/.compiz
  • sudo rm -fr ~/.Xauthority sudo rm -fr ~/.config/autostart
  • $ mv ~/.config/dconf/user ~/.config/dconf/user.old

Of course, not in this order, just to show what i,ve tried so far. Please help as my means of income is my computer!

0

Hmm... it sounds weird...

Try to:

→ Delete all the .* folders in your home, such as .config, .local, .cache, etc. (this will delete all your programs configuration, so backup something in those folders which you would want to restore later)

→ Remove all the Unity and Compiz stuff (Ctrl+Alt+F1, login on that screen, and put: sudo apt-get autoremove --purge ubuntu-desktop unity compizconfig-settings-manager), but don't touch Nvidia packages). I have read that you have logged in and have seen an Xfce box (a loading screen). Maybe the system have messed up if you have installed various desktop environments. Delete Xfce (sudo apt-get autoremove --purge xfce4-panel xfce4-session xfdesktop4 thunar xfce4-settings xfconf xubuntu-desktop).

→ Try reinstalling Unity (sudo apt-get install ubuntu-desktop unity) or switch to another desktop (you can try again with Xfce (sudo apt-get install xubuntu-desktop) or switch to MATE (sudo apt-get install ubuntu-mate-desktop), which I prefer over Unity, as it is more lightweight and faster, and also resembles the Ubuntu good old days (GNOME 2))

*Come to this page and put your results in the Comments section of this answer.

*If you still have the problem, and don't have a separate home partition, consider to backup your stuff and reinstall Ubuntu. If you have that separate partition, then you wouldn't need to backup your things, as long as you are careful when installing the Ubuntu. By the way, only do this if the "→" instuctions don't work.

Hope this helps...

  • Thank you this worked! I m able to use the computer again, all my fies and bookmarks are there. only thing missing is the internet icon in panel, but hey, that s small fish now. Thank you again – Kme Aug 18 '16 at 23:46
  • PS. have installed Mate, in all the process was very fast, less then 20 min comparing six hours of trying other commands – Kme Aug 18 '16 at 23:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.