In Lubuntu, there's no 'Add New Program...' button in Desktop Session Settings. Is there an easy way to add new autostart programs in Lubuntu?

up vote 24 down vote accepted

For Lubuntu 11.10 / 12.04 / 12.10 / 13.04 / 14.04 / 14.10 / 16.04

Open the file manager (by default PCManFM), go to /usr/share/applications. Right-click on the program you want to be added to your autostart programs, and click Copy. Now, go to ~/.config/autostart in PCManFM, right-click and click Paste. The program should be added to your autostart programs now, but double-check by clicking the LXMenu down left, click Settings, and then Desktop Session Settings.

You may have to create the autostart folder. For an application that doesn't have a *.desktop file in /usr/share/applications you may also copy-paste any other *.desktop then update it with content suitable for your app.

  • Not working for me, fresh install Lubuntu 13.10. – Vitaly Zdanevich Oct 21 '13 at 5:54
  • Can confirm that it works for Lubuntu 14.10 – dani-h Apr 5 '15 at 23:35
  • Just tried and it's working in Lubuntu 16.10. To verify using the GUI, go to the LXMenu > Preferences > Default applications for LXSession and select the Autostart tab. In the Known Applications list, check to see that the added applications are listed and checked. – Tim McElwee Mar 19 '17 at 20:22

For Lubuntu 13.10

~/.config/autostart trick does not work in Lubuntu 13.10, but commands which are put in ~/.config/lxsession/Lubuntu/autostart file will be run automatically after login. Read more about it in this Ubuntu Forums post.

If you want to do it graphically, go to Preferences/Default applications for LX Session, then select the Autostart tab.

  • worked for me! thank you – Tebe May 13 '14 at 19:03

For Lubuntu 13.10

In my example, I'll autostart cairo-dock.

  1. Create a file called .starter in your home dir and make it executable:

    touch ~/.starter
    chmod +x ~/.starter
    
  2. In that file write the command you want to be autostarted, save and close:

    leafpad ~/.starter
    
  3. Edit the autostart file in the lxsession directory:

    sudo leafpad /etc/xdg/lxsession/Lubuntu/autostart
    
  4. Add this new line:

    @/home/user/.starter ## Replace user by your name
    
  5. Save and close

  6. Reboot and it shall now run automaticaly

I've had to do this a few times and the .desktop 'trick' never works for me. add the command to the autostart file: /etc/xdg/lxsession/Lubuntu/autostart

See this question for details.

Make a new shorcut to the program in your ~/.config/autostart directory.

For example, to make the drop-down terminal Guake start automatically, type this in a terminal:

cd ~/.config/autostart
ln -s /usr/share/applications/guake.desktop guake.desktop
  • 2
    Maybe you can expand your answer to explain how! – stephenmyall May 27 '13 at 19:11

you can manage them after installing lxsession-edit but don't know if that's what you want to achieve. otherwise the other answers are pretty good, the "official" guide is here: http://wiki.lxde.org/en/LXSession#Autostarted_applications_using_lxsession

There's a thread about this on the Ubuntu Forums.

I'm using Lubuntu 13.04 on a Samsung NC110 netbook, 2GB RAM.

A procedure that worked for me was:

  1. cd /etc/xdg/lxsession/Lubuntu
  2. sudo nano autostart
  3. Add programs wanted, save and exit.

Directly putting cli commands in autostart file causes lxsession user preferences to not load, thus I added bash filename.sh into autostart (no /bin/ pathname necessary) and achieved my purpose)

I had originally wanted to try to

  1. reactivate LibreOffice Quickstarter
    • Make bash file with libreoffice --quickstart --nologo –nodefault
    • Place bash filename.sh in /etc/xdg/lxsession/Lubuntu/Autostart file) and have pcmanfm to autostart up to my most commonly used directory (pcmanfm pcmanfm /media/a/LG/AC/Learn/).

Again, hope everyone can learn from my mistake. Definitely do not put regular cli commands directly into Autostart and expect them to execute normally, neither my desktop background, pcmanfm preferences (specifically the directory would open in icon view rather than my preference which is detailed view), nor my symbolic links loaded each time after bootup, and I was left with a desolate gray screen.

As soon as I deleted the cli commands and replaced it with bash file names, everything went back to normal.

I followed Exeleration-G's graphical plan for adding VirtualBox in autostart. I expected it to work when I logged out and in again, but the first time it didn't. I rebooted the computer and it started right up. Ever since then, it loads when I log out and log back in again even when I closed V'Box before logging out.

I am using Lubuntu 16.04 LTS.

In Lubuntu (Ubuntu) 17.10, I succeeded in using the file:

.config/lxsession/Lubuntu/autostart

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.