1

I am currently running version 15.10 of Ubuntu, and today system requested an upgrade to 16.04. I ran the upgrade but it stopped mid-way due to low disk space error. I cleaned up old kernels, leaving just the one I am currently running, but it still didn't make up enough space for the upgrade. Here is my current kernel list:

ii  linux-image-4.2.0-42-generic       4.2.0-42.49  amd64        Linux kernel image for version 4.2.0 on 64 bit x86 SMP
ii  linux-image-extra-4.2.0-42-generic 4.2.0-42.49  amd64        Linux kernel extra modules for version 4.2.0 on 64 bit x86 SMP
ii  linux-image-generic                4.2.0.42.45  amd64        Generic Linux kernel image

ii  linux-headers-4.2.0-42         4.2.0-42.49  all          Header files related to Linux kernel version 4.2.0
ii  linux-headers-4.2.0-42-generic 4.2.0-42.49  amd64        Linux kernel headers for version 4.2.0 on 64 bit x86 SMP
ii  linux-headers-generic          4.2.0.42.45  amd64        Generic Linux kernel headers

and here is the df -h result:

Filesystem      Size  Used Avail Use% Mounted on
udev            1,9G     0  1,9G   0% /dev
tmpfs           388M  6,5M  381M   2% /run
/dev/dm-1       454G   15G  416G   4% /
tmpfs           1,9G  160K  1,9G   1% /dev/shm
tmpfs           5,0M  4,0K  5,0M   1% /run/lock
tmpfs           1,9G     0  1,9G   0% /sys/fs/cgroup
/dev/sda2       237M  119M  106M  53% /boot
/dev/sda1       511M  3,4M  508M   1% /boot/efi
tmpfs           388M   48K  388M   1% /run/user/1000

This is the error message (after the old kernel clean-up):

Not enough free disk space 

The upgrade has aborted. The upgrade needs a total of 183 M free 
space on disk '/boot'. Please free at least an additional 72,6 M of 
disk space on '/boot'. Empty your trash and remove temporary packages 
of former installations using 'sudo apt-get clean'. 

I have tried sudo apt-get clean and my trash is empty. Is there anything else I can do to free more space in /boot?

  • Why is /boot mounted on a different partition? – anonymous2 Aug 18 '16 at 13:23
  • I cannot answer that, I was not the one who installed the OS. Is there a way to switch it to /dev/sda1 while avoiding a clean reinstall? – DonSpark Aug 18 '16 at 13:27
  • Hmm, possibly, but it could be pretty tricky. Probably better to grow the partition, as @KratsYnot suggested. – anonymous2 Aug 18 '16 at 13:33
  • Check out askubuntu.com/questions/280211/… – anonymous2 Aug 18 '16 at 13:33
-1

Perhaps resize the partition?

This suggests apt-get autoremove, if you have not tried that

  • Thanks a bunch, I haven't thought as far as resizing the partition. I will try that, cheers! – DonSpark Aug 18 '16 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.