3

This is related to No sound after 14.10 -> 15.04 -> 15.10 upgrade

After the upgrade, there is no sound over the headphones. I can use the same solution in the linked question (in pavucontrol, select "Analog Stereo Output (unplugged)", I also need to select "Headphones (unplugged)" in the "Output Devices" tab, because by default it's Line in). The problem is every time I lock the screen, when I unlock it I need to do these same steps, since it reverts to "Digital Stereo (HDMI) Output".

Something I noticed is that, if I insert the headphones halfway into the jack, the "Analog Stereo Output" (i.e. plugged) appears in the list, but it disappears after I fully insert it. The headphones are working fine, and this didn't happen in 14.04. So, my question is how to either:

  • Fix this; or
  • Disable jack detection (I only listen using the headphones); or
  • Force the selection of "Analog Stereo Output (unplugged)"

        $ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: VT1705 Analog [VT1705 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: VT1705 Digital [VT1705 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 2: VT1705 Alt Analog [VT1705 Alt Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    
  • Small update: I've disabled HDMI audio in the BIOS and now it keeps the Audio Stereo Output selected when unlocking the desktop. I still need to change it everytime I boot, but it's much less annoying. – Conrado Aug 26 '16 at 11:42
0

I encountered the exact same problem with my stereo plug not being recognized after I changed something with my audio setup but the audio still being output when I selected it manually.

I found my solution in a similar question: I was using the wrong plug on my board. Switching it from the teal-colored rear speakers to "Line Out" (green) now properly makes pulseaudio detect my device and I don't need to disable HDMI output every time the monitor comes back from standby.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.