9

I have Ubuntu X64 running and I have installed dolphin and packages like kffmpegthumbnailer, mplayerthumbs, ffmpegthumbs mainly found here. Even after that I cannot see thumbnails. Any idea what's wrong. Check the screenshot below :

enter image description here

Thank you.

2
  • Do you have the kio-extras installed ?
    – user26687
    Commented Aug 18, 2016 at 18:37
  • Yes.. that's the last thing i did.. i finally installed kubuntu-desktop.. when i login from kde..i see thumbnails...but in unity login..i dont.. Commented Aug 18, 2016 at 18:44

4 Answers 4

10

I had exactly the same issue. I used

sudo apt-get install kio-extras

and now it works well. You might need to go to

Settings>Configure Dolphin...>General>Previews

and then select whatever you need. Then of course press the "Previews" button if you haven't or go to View>Previews, but at least images should be by default. I also read that for some other formats (that I'm not using, so I haven't tested it) you should try

sudo apt-get install ffmpegthumbs

sudo apt-get install mplayerthumbs

sudo apt-get install kffmpegthumbnailer

I hope it works for you too!

1
  • This still works flawlessly in 2023. Thank you!
    – Longblog
    Commented Jul 17, 2023 at 4:40
0

i'm reviving this old thread because the title describes exactly my case. After updating Kubuntu from 21.10 to 22.04, I had the problem "Dolphin not showing preview of images or any files". Some times it just worked. Some times, if I reloaded [F5] the directory, I was able to see the thumbnail of the file I had selected before. But mostly, no previews.

What worked for me, was to delete/rename the /home/USER/.cache and restart Dolphin. Hope someone finds this useful :=)

EDIT: This problem keeps coming back. While dolphin is recreating the cache (i'm viewing a folder of 500 files and 20 subfolders) at some time throughs this on konsole:

libpng warning: known incorrect sRGB profile
libpng warning: profile matches sRGB but writing iCCP instead

After this, I have to re-delete the cache folder and restart.

EDIT2: Ok, I'm narrowing down a little. If I select a file, lets say a .jpg or a .txt, and scroll a little up or down, viola! the thumbnail gets refreshed and appears! At the same time on konsole:

Qt: Session management error: networkIdsList argument is NULL
1
  • Same problem here. In Configure/Previews, there's the peculiar question "Skip previews for remote files above", where the choices are "no previews" and various sizes. I don't know how to answer that if I simply want all previews. In any event, I can only preview jpegs one at a time by clicking on them.
    – Paul A.
    Commented Oct 27, 2022 at 22:39
0

This is an old question but there's another simple answer that hasn't been mentioned. You might need to press space to toggle previews.

0

SOLUTION, for me, at least

Hello dears, I 'd like your help here:

  1. Enable preview in Dolphin (I have the "info" panel shown on the right)

  2. Create an empty m3u8 file and paste inside

    #EXTM3U #EXT-X-VERSION:3 #EXT-X-TARGETDURATION:2 #EXT-X-MEDIA-SEQUENCE:123 #EXTINF:11, cd_117871.ts

enter image description here

  1. Save Now preview in Dolphin is totaly not working.

  2. add a space as the very first character of the file. Save. Now preview in Dolphin is working again.

What have we learned? Something is wrong with the previewing mechanism.

So, if you have such files laying around your folders, if you ever visit the folder, preview of dolphin stops working. Remove them.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .