Home-made PC, reasonably new CPU and motherboard. Previously I had a Geforce GTX 750 Ti. With the GTX 750 Ti, I was able to install 14.04. The open source drivers worked just fine. Installing the Nvidia proprietary driver was also fine. The 750 also worked great on Win 7 and Win 10.

I've replaced the GTX 750 Ti with a Titan X Pascal (the 2016 model). Trying to boot into the previously installed Linux seemed fine until it switched from text mode to graphics mode - then all I got was a blank screen. That was with the Nvidia proprietary driver installed.

Ok, no problem, I was planning to reinstall anyway.

So I'm booting the 14.04 installer, and I have the same issue. All goes well until it's switching from text mode to graphics mode. Then the screen goes blank. Selecting "try without install" doesn't help - I have the same issue. With the installer, this is an issue with the driver that comes with the installer (probably different from the Nvidia proprietary driver).

I can't even install the OS with the new graphics card.

The graphics card works just fine on the same system under Windows 10. The system is connected to a TV screen (1920 x 1080) regardless of the OS it's booting.

Please note installing a newer OS (such as 16.04) is not an option, since this system will be used for machine learning, and some libraries and tools have not been ported yet to 16.04. So I must solve this issue with 14.04.

Any suggestion is appreciated - I'm stumped.

  • 1
    It's possible and probable that 14.04 just doesn't support the card OOTB, since it's so new. Try just booting into a 16.04 live environment and seeing if it works there. You can also try pressing e on the Try Ubuntu option, putting nouveau.modeset=0 at the end of the line beginning with linux and then pressing F10 to boot. If it works, that'll at least let you install. Do the same thing in GRUB after installation to boot into the OS, then install drivers. – TheWanderer Aug 18 '16 at 3:26

NVIDIA have a 64-bit Linux driver on their site for this card. What you may have to do is install (from the command line) either:

  • nvidia-367
  • nvidia-367-updates
  • the package you download from Nvidia (try wget)

I believe nvidia-current isn't an option, as that seems to be version 304, whereas you need version 367 or better. See this related question, pay special attention about adding a PPA, blacklisting nouveau, and do try ubuntu-drivers.

  • Just curious - why is it sometimes recommended to blacklist nouveau? – Florin Andrei Aug 18 '16 at 17:16
  • 1
    @FlorinAndrei My understanding is that nouveau is prefered by the kernel, therefore it would get loaded first (before the nvidia proprietary driver) and prevent the nvidia proprietary driver from either loading or taking over the display. – tlhIngan Aug 18 '16 at 17:20
up vote 0 down vote accepted

It turns out I was trying to install Ubuntu 14.04.4, which is not the latest version.

I've downloaded the 14.04.5 image and tried it, and it works. The installer is able to switch from text mode to graphics mode on the Titan X, and it allowed me to complete the installation.

The installed OS also boots up just fine and is able to switch to graphics mode.

One remaining issue is that it doesn't switch to 1920 x 1080 - the native resolution of the screen. It was able to do that on the GTX 750 Ti, but not on the Titan X. On the Titan X it switches to a lower resolution. I am going to install Nvidia's proprietary driver and see if that fixes the resolution. But this is a separate issue from the original one.

EDIT: Installing the Nvidia proprietary driver fixes the resolution issue.

  • Hows it running for you? I'm about to place my Titan X Pascal order! – xendi Oct 23 '16 at 8:22
  • @xendi Like I said, works fine with 14.04.5, and all issues are solved once you install the Nvidia driver. However, meanwhile I have switched to 16.04 and I have no issues with the Titan X Pascal at all. – Florin Andrei Oct 24 '16 at 19:31

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.