2

On my Asus, with Kubuntu 14.04, If I plug the headphones audio still plays form both outputs (speakers and headphones). I can fix this problem manually after the boot with alsamixer or Phonon, but it's irritating. I know this is a know issue and It was fixed on 16.04 release, but i can't upgrade to this version. So, how can I fix this problem?

lspci -nn | grep -i audio
00:1f.3 Audio device [0403]: Intel Corporation Device [8086:9d70] (rev 21)

aplay -l
**** Lista di PLAYBACK dispositivi hardware ****
scheda 0: PCH [HDA Intel PCH], dispositivo 0: ALC256 Analog [ALC256 Analog]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 0: PCH [HDA Intel PCH], dispositivo 3: HDMI 0 [HDMI 0]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 0: PCH [HDA Intel PCH], dispositivo 7: HDMI 1 [HDMI 1]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 0: PCH [HDA Intel PCH], dispositivo 8: HDMI 2 [HDMI 2]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0

amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 60 [69%] [-20.25dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'

http://i65.tinypic.com/20aou49.png

Solutions that I tried (without success):

  • Edit alsa-base.conf:

echo "options snd-hda-intel model=auto" | sudo tee -a /etc/modprobe.d/alsa-base.conf

    echo "options snd-hda-intel model=asus" | sudo tee -a /etc/modprobe.d/alsa-base.conf

    echo "options snd-hda-intel model=laptop" | sudo tee -a /etc/modprobe.d/alsa-base.conf

    echo "options snd-hda-intel position_fix=1 enable=yes" | sudo tee -a /etc/modprobe.d/alsa-base.conf

    echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf

(not together)

  • What is your exact hardware? Is it Asus laptop or PC? Have you updated your 14.04 by sudo apt-get update and sudo apt-get upgrade? – Léo Léopold Hertz 준영 Aug 29 '16 at 19:55
  • 2
    It is actually an Asus laptop F555UJ-DM059T and yes, I did updates by terminal and sometimes by KDE Update Manager. – Mike Aug 30 '16 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.