I have currently configured a Ubuntu web development server machine, but am having problems connecting/viewing Adminer on the local network. e.g. I can connect to Apache without any problems from a different machine using the local network IP e.g. fine. But when I try to access i get the:

Not Found

The requested URL /adminer was not found on this server.

On the Ubuntu web development server machine, i can access adminer via on localhost. e.g., the same as Apache.

I would like to know what would be the correct config, to make adminer reachable without playing around with my DNS/host settings on the other networked computer.


I found on Ubuntu 16.04 that after installing Adminer via

sudo apt-get install adminer

it didn't correctly set up the Adminer Apache configuration file. I did the following to get it working:

cd /etc/apache2/conf-available
sudo ln -s ../../adminer/apache.conf adminer.conf
sudo a2enconf adminer
sudo service apache2 reload

After that the it worked locally and remotely for me

| improve this answer | |
  • Yup I had the same issue in Ubuntu 16.04. The apt install script for Adminer is buggy. – Crouching Kitten Aug 22 '17 at 12:32
  • I had same issue and with above steps it worked ! Thanks. – srv Feb 11 '18 at 10:21

I don't think viewing just the file will solve the problem. At least mine didn't. If you installed Adminer through the command line like this sudo apt-get install adminer, the apache configuration will be found in /etc/adminer/apache.conf file.

You have to Include this configuration file in your apache configuration which is usually found in /etc/apache2/apache2.conf file. If so, through the command line type sudo gedit /etc/apache2/apache2.conf and at the bottom of the file add Include /etc/adminer/apache.conf or the file path your adminer configuration. Restart your apache server by typing sudo service apache2 restart. If you browse for localhost/adminer you should get everything up and running like this.

Final screenshot of Adminer up and running

| improve this answer | |
  • Welcome to Ask Ubuntu. You can improve your answer by including the command needed to restart Apache. Thank you. – WinEunuuchs2Unix Dec 27 '16 at 0:15
  • Thank you. I assumed those who know about Adminer should already familiar with restarting apache server. By the way, I've done that. – Tanveer Rahat Dec 27 '16 at 11:04

Solved: By viewing the file in /etc/apache2/conf-available named: adminer.conf.

This then contains the Alias names, the file reads:

Alias /adminer.php /usr/share/adminer/adminer.php

I then went onto the other machine on my network and typed in:

And it worked!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.