5

Hello and thanks for visiting my question thread.

My laptop is Asus X45A. I fresh installed Ubuntu 16.04 because I cant upgrade it from previous LTS. Then I installed another desktop environment which is Lubuntu because it is lot lighter.

My laptop only has one jack slot of sound, for sound in, sound out or both. So I use my Samsung headphone to listen to the sound and to record my voice. This can be done very good in my Windows 10 with Realtek (my laptop is dualboot)

When I try it in Ubuntu, I can listen for the sound very good, but unfortunately, the microphone of the headphone is not working. The microphone is detected in pavucontrol, and the range bar is moving BUT randomly and not depend on my voice.

Another thing I want to tell you is, when I press volume up, down or the answer button in my headphone, the bar moving to the corner right, like when the input sound is very loud.

I notice the different between input and output devices tab in pavucontrol. In output devices tab has headphones listed but with "(plugged in)", so it say "Headphones (plugged in)" but in output devices there is just "Microphone without plugged in text or else.

I have try few things and didn't work, and unfortunately I dont remember all the steps that I try. Like changing the alsa-base.conf and alsamixer for example, and any else. So I'll post a result of few commands that maybe helpful to solve my problem.

Sorry for my english if it's hard to read, I'm still learning hehe. If there any else command that I have to run, please post here. Thanks for your support :)


Here is the link of the screenshot of my pavucontrol "Input Devices" tab: (I cant thumbnail the uploaded image yet) as you can see, the microphone is detected and the bar is moving like it has input sound but it moves randomly not depending on my voice

My alsamixer: I just playing with alsamixer

When I run "cat /proc/asound/cards" the result is:

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7e10000 irq 30

The result of "sudo gedit /etc/modprobe.d/alsa-base.conf"

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2


options snd-pcsp index=-2

alias snd-card-0 snd-hda-intel

alias sound-slot-0 snd-hda-intel

options snd-hda-intel model=asus-x45a

options snd-hda-intel enable_msi=1

options snd-hda-intel position_fix=1 enable=yes
  • I have basically identical problem but in my case the laptop is Acer TMP648-MG-554H. If you even sumbled upon anything that is at least related to these issues, I would love to hear it. It drives me crazy. – zegkljan Feb 13 '17 at 10:13
0

Alsamixer is nice, yoU can see devices that are off by accident. However I don't thinkits usage is entirely clear.

I also use pavucontrol for same purpose. For me, it offers better view of devices. I often find headset volume is set at 00, have to increase. In the recording panel, it has excellent self awareness.

This is worth testing, I still use daily to switch sound input and output devices while recording screencasts.

  • This is not even an attempt to an answer, just a plain comment totally unrelated to solving this problem. – zegkljan Feb 13 '17 at 10:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.