3

At the moment I have a 3.1 kernel installed from elsewhere and the regular 3.0.12 (upgraded to 3.0.13 today) kernel from the repos. When booting up, GRUB will choose 3.1 by default. I want it to choose 3.0.12/13 by default. How can I make it do that?

1

Edit /etc/default/grub with your favorite text editor, ie

sudo nano /etc/default/grub

Locate the line

GRUB_DEFAULT=0

Change it to the line you want to boot from default, to see which line you want press the key Shift right after your computer computer's POST and keep it pressed, Grub will show the lines available to boot, the fist one is 0, the 2nd one is 1, etc. Insert the value you want in GRUB_DEFAULT=.

| improve this answer | |
1

I liked Bruno's suggestion but all my secondary options were under a "Previous Linux versions" submenu, so I wasn't 100% sure how that would affect the numbering, and I'd prefer a GUI option if there is one.

Firstly, do not use StartUp-Manager (startupmanager), it is no longer maintained and according to reviews in the Software Center no longer works.

Instead install Grub Customizer, recommended by the author of StartUp-Manager and currently only available from a PPA.

Once installed, run it and select Preferences. In the first tab (General) there is an option for defaults. "Previous Linux versions" are marked 4 > 1, 4 > 2 and so on. Select the one you want.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.