0

I configured a remote desktop yesterday over LAN by setting up Vino to allow direct (no tunneling) connections on the host PC and using Remmina with VNC password based authentication. It worked yesterday, but I could not connect anymore today.

The plan today was to connect through SSH tunneling instead of direct connection. Here are some settings I made on my server this morning (after it already failed to establish password based connection):

  • gsettings set org.gnome.Vino network-interface lo
  • gconftool-2 --set --type=bool /desktop/gnome/remote_access/enabled true
  • changed my vino pass with vino-passwd
  • And of course my openssh server was set to allow TCP port forwarding..

It is entirely possible that the network admin or the router silently blocked VNC. How can I test that? Direct VNC is possible to localhost on both my host and my local PC. I also have direct access to my host, they are both on my desk. And SSH login to the host also works.

Edit: Some details on my tunneling. The behavior is that Remmina is left waiting to connect forever.

$ sudo lsof -i -n | egrep '\<ssh\>'
sshd       8855   root    3u  IPv4 102675      0t0  TCP x.x.x.x(host ip):ssh->x.x.x.x(local ip):44732 (ESTABLISHED)
sshd       8881 (username)    3u  IPv4 102675      0t0  TCP x.x.x.x(host ip):ssh->x.x.x.x(local ip):44732 (ESTABLISHED)
sshd       9037   root    3u  IPv4  98126      0t0  TCP *:ssh (LISTEN)
sshd       9037   root    4u  IPv6  98128      0t0  TCP *:ssh (LISTEN)
sshd      10843   root    3u  IPv4 118036      0t0  TCP x.x.x.x(host ip):ssh->x.x.x.x(local ip):45428 (ESTABLISHED)
sshd      10911 (username)    3u  IPv4 118036      0t0  TCP x.x.x.x(host ip):ssh->x.x.x.x(local ip):45428 (ESTABLISHED)
  • I don't think it's possible for anything to "silently block" VNC traffic once it's within an SSH tunnel. Can you include details about how exactly you set up the tunnel - are you using Remmina's own tunnel setup, or creating the tunnel manually using an SSH command? Also was the server's VNC port accessible to the internet during yesterday, or only to your private network? It doesn't take long for script kiddies to discover unprotected VNC posts unfortunately. – steeldriver Aug 16 '16 at 10:21
  • The thing is yesterday it worked with no tunneling. (I had not time to set it up) So it was simple password based VNC, and the LAN is of course firewalled, but I made no effort to block the port yesterday. I did however turned off my host PC for the night and rebooted in the morning. This morning I was using Remmina's tunnel setup. Is it possible to use Remmina with my custom SSH port forwarding? How? – grokkaine Aug 16 '16 at 10:44
  • Well, I've seen situations where VNC "worked yesterday" but "today" is effectively DDOSed by a barrage of connection attempts from bots/kiddies - you were wise to reconfigure it to only listen on the localhost interface. As to why it's not connecting since you did that, it's hard to say without details of your tunnel setup and "custom port forwarding". – steeldriver Aug 16 '16 at 10:52
  • OK thanks, added some tunneling details. But keep in mind that yesterday there was no tunneling, and the connection was direct not via SSH. That is what doesn't work today, the SSH tunneling is my end goal (prepping up my remote desktop to be opened to internet eventually). – grokkaine Aug 16 '16 at 11:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.