7

I am trying to connect to a VPN via L2TP over IPsec in Ubuntu 16.04. I know a small handful of posts here and bug reports have begun to document this issue, but I believe my experience, if somewhat naive, may add to the discussion, and perhaps I am overlooking something that may make it work for me.

First, I followed the instructions here to successfully install network-manager-l2tp: https://github.com/nm-l2tp/network-manager-l2tp

The L2TP option then appeared for the first time in my Add a Connection Type dropdown.

I started a new L2TP connection and entered the IP address, my user name, and my password.

Then I clicked on "IPsec Settings" and entered my shared secret.

When I try to connect to the VPN, I get the error in the upper right corner of the screen "VPN Connection Failed: The VPN connection failed because there were no valid VPN secrets."

I also tried the instructions here, and got the same error: https://github.com/nm-l2tp/network-manager-l2tp/issues/12

I have tried restarting, etc. I do not know what this error means. Thoughts?

1
0

Make sure you set the Phase 1 and Phase 2 protocols if your server doesn't properly support auto-negotiation or uses a potentially insecure protocol. You can try 3des-sha1-modp1024 for Phase 1 and 3des-sha1 for Phase 2 (these were common protocols but they are now insecure so don't get attempted automatically).

If you install the ike-scan package you can run sudo ike-scan YOUR.SERVER.IP and it should return at least 1 valid supported protocol. For Meraki Client VPN it is the one I mentioned above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.