1

I'm trying to compile a program.

I first found out I needed the SDL1.2-devel package so I installed them all (manually, probably didn't do it right).

Before I installed SDL-dev packages, I couldn't run ./configure (missing sdl error)

Now I can run configure, but when I run make, I get this output:

libtool: link: gcc -g -O2 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -Wall -g -DPREFIX=\"/usr/local\" -DDATA_PREFIX=\"/usr/local/share\" -o gnujump game.o game-input.o game-output.o game-logic.o game-tools.o game-timer.o main.o menu.o menu-system.o records.o SDL_2dgl.o SDL_rotozoom.o setup.o SFont.o sprite.o surface.o tools.o replay.o effects-trail.o effects-blur.o -Wl,-rpath -Wl,/usr/lib -L/usr/lib /usr/lib/libSDL.so -lpthread -lSDL_image -lSDL_mixer

gcc: error: /usr/lib/libSDL.so: No such file or directory

Makefile:376: fallo en las instrucciones para el objetivo 'gnujump'

make[2]: *** [gnujump] Error 1

make[2]: se sale del directorio '/home/mauro/Sluggy/gnujump-1.0.8/src'

Makefile:357: fallo en las instrucciones para el objetivo 'all-recursive'

make[1]: *** [all-recursive] Error 1

make[1]: se sale del directorio '/home/mauro/Sluggy/gnujump-1.0.8'

Makefile:288: fallo en las instrucciones para el objetivo 'all'

make: *** [all] Error 2

(I know it's in spanish. It basically says: "instructions failed" and "leaving directory").

I think the problem may be in the installation of SDL. I did it manually using the package from the official web.

I appreciate help of any kind. Thanks.

1

To install libsdl1.2-dev in an "official" way, run:

sudo apt-get install libsdl1.2-dev

After that you might need to run .configure again.


The libSDL.so is not placed directly in the /usr/lib. The package from APT configures the path by placing a file in /etc/ld.so.conf.d/, for example:

$ cat /etc/ld.so.conf.d/x86_64-linux-gnu.conf
# Multiarch support
/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu
  • I already installed libsdl1.2-dev in all official and unofficial ways possible xD. Ok. So I searched in /usr/lib and found a broken shortcut to "libSDL.so". So It seems all I need to do now is to find the correct file and fix the link. But that file is not in /etc/ld.so.conf.d/. ... – mauroc8 Aug 16 '16 at 20:23
  • Now I found it in /usr/local/lib. There was a libSDL.so linking to "libSDL-1.2.so.0.11.4". In /usr/lib I had only the link, not the file, and thus it didn't worked. I copied libSDL-1.2.so.0.11.4 to /usr/lib. It should work now – mauroc8 Aug 16 '16 at 20:23
  • Okay so it worked. I still can't compile the damn thing because now make throws a different error, but I guess I'll have to make another thread for that one. Thanks :) – mauroc8 Aug 16 '16 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.