2

I was trying to install Rainlendar2 in the "Try Ubuntu" Desktop from a live USB for both the 32 & 64 bit computers. After downloading Rainlendar2 and extracting the folder/file, the Rainlendar2 icon does not appear on the desktop, although it is shown installed in Ubuntu Software Centre. I tried launching Rainlendar2 from the Files and receive error message that the Archive Manager could not open Rainlendar2.

I would appreciate it if Ubuntu Community could offer any assistance & advice.

  • 1
    What did you mean by "downloading & extracting"? if you downloaded it from their site, Ubuntu software center won't show it as installed! What were the error messages? If you can't comment, edit the question to include these information. – Anwar Aug 16 '16 at 4:25
1

The correct way to install RainLender in Ubuntu 16.04 is as follows

  1. Download the .deb file from their download site labeled with (Debian/Ubuntu). I am here demonstrating from terminal for 64-bit architecture.

    wget -c http://www.rainlendar.net/download/rainlendar2-pro_2.13.1.b147-1_amd64.deb
    

    Change the link to pro or lite depending on your need in the command.

  2. Once the download is complete, install it with dpkg

    sudo dpkg -i rainlendar2-pro_2.13.1.b147-1_amd64.deb
    

    Again change the filename accordingly. The terminal can autocomplete the filename for your if you press Tab key twice quickly.

Though this will install rainlender, but the software would stay in unconfigured, because some of it's dependency will not be satisfied. You may see the output like this after

Selecting previously unselected package rainlendar2-pro.
(Reading database ... 651477 files and directories currently installed.)
Preparing to unpack .../rainlendar2-pro_2.13.1.b147-1_amd64.deb ...
Unpacking rainlendar2-pro (2.13.1.b147-1) ...
dpkg: dependency problems prevent configuration of rainlendar2-pro:
 rainlendar2-pro depends on libwebkitgtk-1.0-0; however:
  Package libwebkitgtk-1.0-0 is not installed.

dpkg: error processing package rainlendar2-pro (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160523-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 rainlendar2-pro
  1. To fix this dependency problem, again type in terminal

    sudo apt-get -f install   
    

    It will then download and install other packages to fullfill dependencies and you can then run it.

Here is the screenshot running RainLender in my Ubuntu (with KDE5)

image - RainLender running on Ubuntu

| improve this answer | |
  • Anwar, I've tried the terminal method according to your kind advice above but still no rainlendar2 icon or app installed. Just as with the previous How-To Geek method, the deb package folder is shown in FIles. Could it be that I am trying to install in "Try Ubuntu" desktop environment and not the "Install Ubuntu" desktop environment ? – cch Aug 16 '16 at 15:26
  • I don't think so. Live Session should not be that limiting. Have you installed the deb package successfully? Will you be around to talk about this issue in chat? If yes, let me know when will it be in UTC ? – Anwar Aug 16 '16 at 16:10
  • I had install the deb pkg accordingly but not sure if it was successful. I did your first 2 steps in the above demo successfully but I couldn't tell if the 3rd step was successful as you did not show the output for step 3. In step 3 for my case, I had answered yes to the question in terminal after it had executed completely sudo apt-get -f install. I'm sorry that I'm unavailable for some time as I'll be away but will certainly let you know again when in UTC. Thanks for your excellent follow up on this case. – cch Aug 17 '16 at 3:31
  • 1
    Hi Anwar, I've finally managed to install R2 in Ubuntu although I had to use LTS 14.04.5. It works for both 32 & 64 bit. Moreover, both installation methods (1) using Terminal and (2) Mozilla browser to download from R2 website and open/install in Ubuntu Software Center. From what I could gather on Internet when I googled the issue, many users are facing the same issue when installing apps in Ubuntu LTS 16.04 which apparently have bugs that need to be fix. So, the recommendation is to fallback on LTS 14.0.X or earlier. I think this is an interim workaround till LTS 16.04 is fixed. Anyway, TQ. – cch Sep 24 '16 at 14:20
  • further to my above comment, I can now confirm that R2 is successfully installed in Ubuntu 16.04 LTS after I upgraded from Ubuntu 14.04 LTS. This issue can now be closed. – cch Oct 8 '16 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.