10

I have been solving issues with my ubuntu - windows partition. So after having an issue with the clock of the system and i think this triggering that I couldn't log into my user (it just bounced back) but being free to log like guest, so I created a new user like suggested here.

So, it worked, but now I couldn't load anything although the icon appeared like connected, both wireless and ethernet. So I found a solution... somewhere, that said to add to /etc/resolv.conf

nameserver 8.8.8.8

nameserver 8.8.4.4

So, I found it but it had a symlink to /run/resolvconf/resolv.conf and it didn't exists, so I made one with only said lines. And the internet worked then!!

But when I restart the computer, /run/resolvconf/resolv.conf is gone so I have to make one again each time.

How can I fix this? Apparently there aren't any other symlinks broken, and I have also done this with no result. Thanks everybody

4
  • 3
    Try running sudo dpkg-reconfigure resolvconf and answering 'Yes' when it asks you if you want to prepare /etc/resolv.conf for dynamic updates. Aug 16, 2016 at 0:11
  • @Antonio Kuri Have you tried some of these solutions? Aug 16, 2016 at 15:10
  • Yeah, I just did. Something is missing Aug 16, 2016 at 16:03
  • @AntonioKuri I've updated my answer. Try from the beginning again. Changed step 1. Aug 16, 2016 at 16:12

3 Answers 3

10

You should restore the resolv.conf symbolic link and add required nameservers to /etc/resolvconf/resolv.conf.d/base. Follow these steps:

  1. Reinstall resolvconf package:

    $ sudo apt-get -o Dpkg::Options::="--force-confmiss" install --reinstall resolvconf
    
  2. Add required nameservers to /etc/resolvconf/resolv.conf.d/base:

    $ sudo bash -c 'echo "nameserver 8.8.8.8" >> /etc/resolvconf/resolv.conf.d/base'
    $ sudo bash -c 'echo "nameserver 8.8.4.4" >> /etc/resolvconf/resolv.conf.d/base'
    
  3. Regenerate resolv.conf:

    $ sudo resolvconf -u
    
  4. Restart your network interfaces:

    $ sudo ifdown -a ; sudo ifup -a
    
5
  • When running step 3, it gives back: run-parts: failed to open directory /etc/resolvconf/update.d: No such file or directory Aug 16, 2016 at 15:45
  • @AntonioKuri Ok. Updated my answer. Try again from the beginning. Changed step 1. Aug 16, 2016 at 16:04
  • NetworkManager just crashed while doing nothing. Executable path: /usr/sbin/NetworkManager Aug 16, 2016 at 16:17
  • Did you tried restarting NetworkManager? Aug 16, 2016 at 16:24
  • 1
    Doing the stated worked. Now I restart and the connection works just fine. Thanks Aug 16, 2016 at 16:37
2

I think the resolv.conf is not updated automatically. You can reconfigure it

sudo dpkg-reconfigure resolvconf
0

To solve this problem you need resolvconf, if you don't have it installed,

sudo apt-get install resolvconf

then change the configuration using this file.

sudo nano /etc/resolvconf/resolv.conf.d/base

This make the changes permanent.

1
  • It does make that persistent but doesn't help to fix the connection. No site loads Aug 16, 2016 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.