0

When I install Steam it tells me that it couldn't set up Steam data. I looked that up and the solutions that I found include deleting the .steam folder so that it makes one from fresh. But I don't have a .steam folder, no matter how I install Steam (.deb file installation or using the terminal).

When I use the terminal to launch it, it tells me this:

Repairing installation, linking /home/nik/.steam/steam to /home/nik/.local/share/Steam
rm: cannot remove '/home/nik/.steam/steam': Is a directory
Setting up Steam content in /home/nik/.local/share/Steam
rm: cannot remove '/home/nik/.steam/steam': Is a directory
2
  • How do you know you don't have a .steam directory? The period at the front means that the directory is hidden, so you can see it by running ls -a in ~. Did you try this? – edwinksl Aug 15 '16 at 16:42
  • 1
    Or, in the File Explored (Nautilus, probably), press Ctrl+H to view hidden files and folders. – user308164 Aug 17 '16 at 6:37
1

According to those command outputs, you do have a .steam directory, but it is hidden (because it starts with a .)

Use ls -d .* to show all hidden files or ls -A to show all files

The error is a directory is giving you a hint that you need to use the -r (recursive) flag to remove directories

rm -r .steam

But that is probably NOT the best way to fix your Steam issues. Try this or read this thread for better solutions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.