2

I have following setup:

  • nvidia optimus laptop (Thinkpad P50), using proprietary nvidia driver

  • 2 screens

    • external 1920x1080 screen connected to nvidia card (DP-3.2 in xrandr), it is positioned left of my 2nd screen
    • internal 1920x1080 screen connected to integrated intel card (right of 1st screen) nvidia drivers 367.35-0ubuntu0~gpu16.04.2
  • kernel 4.6.6 (from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6.6/)

When I boot lightdm sets the screens to clone, which is fine.

After login, or when I connect the external screen and use "Displays" utility to extend the desktop to the monitor, following happens

  • external screen to the second screen (the screen "scrolls" when I position the mouse cursor to the right edge) - I had the same issue on 15.10, but it was the only one, I am able to work around this by playing with "Display" utitily (changing orientation, turning screen off etc. could not find a deterministic way to do this)
  • maximized windows span both screens
  • new windows appear in the centre of the whole desktop, not current monitor (= half on first screen, half on second screen)

None of this happens when I move the internal screen left of the external screen.

My xorg.conf: http://pastebin.com/UmAcNVSy

xrandr -q output: http://pastebin.com/SLJNpZTm

xorg.log: http://pastebin.com/J07AT5yq

1
1

Seems it was a bug in nvidia driver fixed in 375.10:

Fixed a bug that caused issues with panning and cursor constraining when mixing PRIME-driven displays with natively driven displays.

from https://devtalk.nvidia.com/default/topic/972585

Installing nvidia drivers version 375.20 (first stable version with the fix above) from ubuntu "graphics drivers" team ppa

resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.