Ever since I did a "clean" install of Ubuntu 16.04 LTS ("Xenial Xerus") on my son's Lenovo G50-45, he cannot start (the new) Ubuntu Software...

We launch the program from the Dash, the "Ubuntu Software" icon appears on the Launcher, then disappears; "gnome-software" is usually shown in System Monitor, however this sometimes disappears after a bit.

How do I fix this issue, so that my Son may actually use Ubuntu Software?

When I enter:


Nothing happens. The cursor simply moves to the next line, there are no error messages, nothing appears to be happening (even after waiting for a bit), "Ubuntu Software" is not shown in System Monitor and no new Terminal prompt is shown.

The same also applies when I enter:

sudo gnome-software

I wasn't expecting "sudo" to make a difference, but I figured there's no harm in trying.

I've already tried, just in case there were any bugs which were addressed in an update:

sudo apt-get update && sudo apt-get upgrade

Which made no difference after a restart.

I also did this with the following commands, restarting in-between each one.

sudo apt-get update
sudo apt-get upgrade

I also tried updating using the following commands, which made no difference.

sudo apt upgrade
sudo apt full-upgrade

Again, I restarted between each attempt.

I have even tried re-installing the Software Center, however this makes no difference.

sudo apt-get --purge remove gnome-software
sudo apt-get install gnome-software

Interestingly, when Ubuntu Software re-installs, it's listed in the Dash as just "Software" with what appears to be the GNOME/generic (unbranded) icon.

For clarification, when I try to launch (the now re-installed) GNOME Software, it does exactly the same thing as was happening in the first place (except with the new logo, this time around)... The same is also true if I try to launch (the now re-installed) GNOME Software using Terminal.

When I enter:

gksudo software-center

I get the Enter your password to do administrative tasks prompt pop-up, but then nothing... Just a brand new prompt (i.e. just like when you first open Terminal).

To be sure, I went through all the steps above again, with a restart in-between purging Software Center and re-installing it.

Also, when I entered:

nano /etc/apt/sources.list

It opens a Terminal-based sources list, but there is no reference to "cairo" or "gusty" (?), only a dozen or so Xenial sources over 54 lines (including spaces)... As I said, this was a "clean" install and courtesy of this Software Center issue, we haven't been able to install anything else.

When I enter:

dpkg -l | grep gnome-software

I get:

ii  gnome-software                              3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1 amd64        Software Center for GNOME
ii  gnome-software-common                       3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1 all          Software Center for GNOME (common files)

The output of:

strace -e trace=open gnome-software

Can be found here.

The output of:

gnome-software --verbose >~/gnome-software.log 2>&1

Can be found here.

It all means nothing to me, but hopefully it means something to one of you guys.

The output of:

which gnome-software



and the output of:

ls -l /usr/bin/gnome-software


-rwxr-xr-x 1 root root 639568 Jun 21 15:57 /usr/bin/gnome-software


The output of:

nano /etc/apt/sources.list

Can be found here.

The output of:

ls -lR /etc/apt/ | grep -v '~'

Can be found here.

  • Just a clarification. The new Software is gnome-software and the classic Software Center is software-center. You could set the sources server to Main Server and try to launch Software Center to see if everything works as intended there, and then try to launch Software. Aug 23, 2016 at 17:24
  • What I do in such situations are first be sure Ubuntu ISO file is healthy by checking its md5 or sha1 checksum. Second make a new boot-able USB and install Ubuntu again. After installation change Ubuntu repository server to main server and run sudo apt-get update, sudo apt-get upgrade and sudo apt-get dist-upgrade ASAP. Now run Ubuntu Software to see what happens.
    – Dante
    Aug 24, 2016 at 12:31
  • I did a "clean" (fresh) install of Ubuntu 16.04... My understanding is that the "classic" Software Center was removed in 16.04, and only the Ubuntu-branded version of GNOME Software is installed by default - am I mistaken? Aug 25, 2016 at 11:26
  • Before you did the "clean install of Ubuntu 16.04" what OS was on the (Lenovo IdeaPad G) laptop? ie Win 8.1, Ubuntu 14.04, etc. Is it stock laptop from 2014 or has SSD been added, etc? Your question asks "how can Ubuntu Software be used"? But you also say you are looking at Dash and Launcher which implies you have booted Ubuntu and are using it already. Can you run Fire Fox? Can you download, install and use Chrome? Can you use LibreOffice Calc or Writer? My point is if you can do all these things it's irrelevant if you can't find "Ubuntu Software" or Gnome Software" the gist of your quest. Aug 26, 2016 at 2:26
  • It's a stock laptop (well, except for RAM - but that changes nothing) and it ran Ubuntu 14.04 LTS prior just fine... But when we upgrade to Ubuntu 16.04 LTS, things went "pear shaped", so I wiped it and started again with Ubuntu 16.04 LTS "fresh". We can use Ubuntu itself just fine - but Ubuntu Software (as in, the re-branded GNOME Software that replaced the Ubuntu Software Center) does not. We want Ubuntu Software to work because aside from the fact that it should regardless, we are having trouble installing other programs (Steam in particular) and I suspect it is linked... Aug 26, 2016 at 8:58

7 Answers 7


I just had the same problem with the same symptoms. Apparently I had a package queued up to install. I needed to reset this by deleting the install-queue file found in the ~/.local/share/gnome-software/ directory. To do this open a terminal window and type this command:

rm ~/.local/share/gnome-software/install-queue

If this doesn't fix your problem, you may have a corrupted configuration file, in which case, I'd simply delete all the files in that directory and let them be rebuilt. That can be done using this command:

rm -r ~/.local/share/gnome-software

I think the highest-voted answers definitely relevant, but I also want to add that for me, old PPA's were causing issues and slowing down Ubuntu Software, even after I removed them from sources.list using add-apt-repository --remove and checked that they were no longer in sources.list. This was because their .list files were still in /etc/apt/sources.list.d and their keyrings were in /etc/apt/trusted.gpg.d.

To remove the .list files one by one:

ls /etc/apt/sources.list.d
sudo rm -i /etc/apt/sources.list.d/<PPAName>.list
sudo apt-get update

Or, to delete ALL PPA's from the sources.list directory:

cd /etc/apt/sources.list.d && sudo rm -i *list*

To remove keys one by one:

sudo apt-key list
sudo apt-key del <KEY_ID>
sudo apt-get update

Maybe reinstall the software center?

sudo apt-get --purge remove gnome-software
sudo apt-get install gnome-software
  • This just replaces Ubuntu Software with "Software" (the ubranded version of Gnome Software?), which does exactly the same thing... Aug 17, 2016 at 7:55

Possible Workaround: Try the Synaptic package manager, it provides similar functionality.

sudo apt-get install synaptic
  • That works - I already have Synaptic installed from when I was trying to fix this issue myself - but it doesn't fix the Software Center issue... Also, I have found that Steam doesn't play nicely with Synaptic. Aug 24, 2016 at 9:23
  • Yeah I know. Wasn't sure if you knew about it (+ I cannot comment). Did you check syslog / apt-logs etc. for anything out of the ordinary? Or try strace and check if there is an error on an apparently important lib / file? strace -e trace=open gnome-software --> produces lots of output but maybe it helps..
    – matt3o
    Aug 24, 2016 at 9:33
  • Okay, the output of strace -e trace=open gnome-software is ridiculously lengthy... Far more than Ask Ubuntu/Stack Exchange will allow me to post. What should I be looking for or is there somewhere I can publicly post it without worrying about length? Aug 24, 2016 at 10:08
  • E.g. pastebin.com, create an unlisted paste. Will look into it later but I cannot promise you to find anything - I'm also no expert in the area. You could also add it as a comment in the main thread maybe there are more experienced guys.
    – matt3o
    Aug 24, 2016 at 10:53
  • It's too big for Pastebin, Ubuntu Forums is whinging about an invalid token or something, it's waaay too big to paste anywhere here... I just can't win. Aug 24, 2016 at 11:40

Possible corrupt media or RAM error. Download new media and re-install. Try another device to confirm a fresh install works fine from the new media on the same network on another device.


i have the same issue and for now i fixed my problem with installing the old ububtu-software-center with this command and it works well :

sudo apt install software-center

I have exactly the same problem. Removing the gnome-software under home directory absolutely resolves my problem.

rm -r ~/.local/share/gnome-software

Update: As Mostafa Ahangarha commented, it is safer if you make a backup of gnome-software first.

cp -r ~/.local/share/gnome-software ~/.local/share/gnome-software-BAK

Then, remove the gnome-software folder by:

rm -r ~/.local/share/gnome-software

Restart ubuntu-software. Ubuntu Software should be able to start now.

If you still cannot see Ubuntu Software started, you can undo the above process by:

rm -r ~/.local/share/gnome-software
mv ~/.local/share/gnome-software-BAK ~/.local/share/gnome-software
  • I suggest to rename or make a backup before removing such settings. Otherwise you might face with a situation that your settings are gone and the problem is still there (perhaps because being related to something else than settings). Removing permanently in the first attempt is not a safe practice Apr 1, 2017 at 8:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .