After I tried to upgrade the kernel of my linux on vps, i get this errors:

When trying to install something

this is for when i try to install sth

When trying to remove something:

this is for trying to remove sth

another error:

root@berbidvps:~# dpkg --configure -a
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: error: 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin

and this is my $PATH:


if it helps my previous system was ubuntu 14.0.4 and before trying to upgrade the system, I added kali repo to download some kali app. After I ran apt-get upgrade and do-release-upgrade to upgrade to Ubuntu 16.04.1 LTS my system got this problem. I removed the kali repo and try to do some fixing, and then these problems happened for me.

  • by some tutorials i try to clean my apt-cache but whenever i run apt-get update all the headers got hit. is there anyway to clean those things to make system to download packages from just ubuntu resources?
    – Lord ST
    Aug 15, 2016 at 8:50

1 Answer 1


In a terminal, run the following:

sudo locale-gen en_US.UTF-8
dpkg-reconfigure locales

That will reconfigure your language settings, which seem to be the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.