1

I've recently set up a mail-server using Postfix, Dovecot and mySQL. Everything works fine except that I can't send email to other mailservers say Google. I get the following error:

Aug 15 11:14:27 server postfix/cleanup[19808]: warning: mysql:/etc/postfix/mysql_virtual_alias_domainaliases_maps.cf lookup error for "mygmail@gmail.com"
Aug 15 11:14:27 server postfix/cleanup[19808]: warning: 82B3F22073: virtual_alias_maps map lookup problem for mygmail@gmail.com -- message not accepted, try again later

I think that postfix tries to somehow authenticate all outgoing email addresses using virtual_alias table, but I can't figure which settings I should change to fix this. I tried Mailx command using ssh session on mailserver and also from macOSX mail client, which both were unsuccessful with the same error.

BTW I used the guide in: https://www.exratione.com/2014/05/a-mailserver-on-ubuntu-1404-postfix-dovecot-mysql/

0

I figured out the problem, it was related to /etc/postfix/mysql*.cf files, which I entered a wrong password in one of them. Now everything works fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.