2

Environment Setup Details

  • Windows 10 Professional
  • Oracle VirtualBox version 5.1.2r108956
  • Ubuntu version 16.04.1 downloaded as ISO image name ubuntu-16.04.1-desktop-i386.iso

Configurations Explained (and attempted)

I have tried almost all setting combinations with this Ubuntu VM via the VirtualBox configuration options where it does not give me the below:

  • "invalid settings detected" enter image description here

The rainbow colored screen below keeps loading with those characters as shown in that screen shot when the VM Ubuntu desktop comes up.

I've updated VirtualBox to the latest version and I've also did the same with the Ubuntu ISO download.


The Rainbow Ubuntu Desktop Load (starburst-style)

  • enter image description here

One VirtualBox VM Configuration

Again I've tried almost all configuration setting combinations just as explained above

enter image description here

What am I missing for this should-be-easy task?

5

Ubuntu VirtualBox Rainbox Screen Fix

After trying different things with the Q&A method here as per the other answers and trying different variations of options for the VM configuration, etc. I decided to take a crack at googling it again and then I stumbled across this post that I figured I'd try to resolve my issue which is similar.

The keys I pressed to resolve were not exactly the same as mentioned in the post in my case for whatever reason, but this post absolutely gave me the pointer for the instruction.

My Solution

When the rainbow screen shows up, I pressed Right Ctrl+F7 together and then let off which popped up the below screen with just the little blinking cursor.

enter image description here

At the blinking cursor screen I pressed Right Ctrl+F1 and then the option popped up to Install Ubuntu or Try Ubuntu as usual—in my case I will always Try Ubuntu and never install it so it'd be nice to have a fix to not have to press these keys per each load of the VM, but that's for a new question—I appreciate all the answers from everyone +1 for all efforts.


Final VM Configs

enter image description here

2

For me, I had to install Ubuntu with the Enable EFI option enabled. I didn't get the rainbow screen at startup. I did have to edit the startup.nsh file after the installation completed, but Ubuntu works great now.

You can see my settings and walkthrough here: http://www.tecklyfe.com/install-ubuntu-16-04-using-virtualbox/

Scroll down to the Troubleshoot Rainbow Startup Screen near the bottom of the article.

  • I keep getting access denied when I type in the edit startup.nsh command and press enter. Does it automatically exist or does it need to be created first? I appreciate you giving me this information regardless +1 and that looks like a familiar rainbow screen pic on the site... LOL!! – Facebook Sep 7 '16 at 20:12
  • Are you typing it at the shell> command prompt after you get the errors? I typed it in and it opened the file, which was empty. Then I copied in the line from my article and saved it. When I restarted, it would give me the error and do the 5sec countdown, then boot into Ubuntu. – Robert Russell Sep 9 '16 at 1:41
  • When I changed the setting on the Ubuntu VM within VirtualBox in the Motherboard tab of "system" and checked the Enable EFI (special OSes only) then saved it. I then booted to the Ubuntu VM and it never popped up the rainbow screen but it does pop up with this screen: i.imgur.com/z4asC5p.png. I type in edit startup.nsh and press ENTER and then this is what occurs: i.imgur.com/mHExHfO.png for the Access Denied. – Facebook Sep 9 '16 at 2:43
  • Rob - I did a little more research and figured it out for what to do to fix in my case so see my answer below when you get a chance. +1 for your efforts regardless. This seems to be related to kernel graphic buffers and incorrect resolution settings from the post in the other article I hyperlinked a few times in my answer. – Facebook Sep 9 '16 at 3:39
1

Ok try setting in system motherboard tab extended features enable all. Processor tab slide to 2 CPU and in the acceleration tab (still on system settings) choose legacy for paravirtualization interface and enable all hardware virtualization.

  • For some reason the Processor option of the processors for the slide bar is grayed out and I cannot change it to 2 CPUs. My PC is Windows 10 64-bit and the processor is Intel(R) Core(TM) i3-4160 CPU @ 3.60GHz 3.60GHz... I've not tried all the suggestion on the other answer yet either. I may need to do some more research, reconfiguration, etc. but I don't recall this being an issue on my old Window 7 PC (different hardware). It may be related to needing to enable virtualization mode in BIOS perhaps... Let me know if you can think of anything based on this feedback. – Facebook Aug 15 '16 at 17:28
1

For me it was as simple as changing the screen controller (in configuration > screen > (In my case the default was svga and I changed it to VirtualBoxVGA)

0

I've installed Ubuntu in Virtualbox no problem, so, I would recommend changing these things:

  • Change Debian 32 bit to Ubuntu 32 Bit
  • Max out the VRam Slider and enable 2D and 3D acceleration (if possible)
  • Try a 64 bit ISO, or an older version (16.04 instead of 16.04.1, then upgrade once installed)
  • If everything above doesn't work, erase that virtual machine and make a new one, with default settings.
  • If all else fails, try uninstalling Virtualbox, rebooting and re-installing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.